summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2015-11-09 23:39:29 +0100
committerFRIGN <dev@frign.de>2015-11-09 23:40:46 +0100
commitd5f6f70d351239ee37b3d864c9a94dc49d66c052 (patch)
tree47993f137fd273df86a4f24fe7fe22098c435e0a /config.mk
parent0b0fcaa7136d7de2e1bc5dc05a576f5fe5608995 (diff)
imagefile -> farbfeld
- Rename the format - Change the format specification - Drop old tools waiting to be fixed on a later date, just keep fixed png for now - Simplify other stuff This is a direct consequence of my slcon2-talk on this topic. At first I planned to have 64 bits per channel, but this is overkill.
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/config.mk b/config.mk
index ceae069..049e12a 100644
--- a/config.mk
+++ b/config.mk
@@ -16,7 +16,7 @@ CPPFLAGS =
#CFLAGS = -std=c99 -pedantic -Wall -Wextra -O0 -g -ggdb ${CPPFLAGS}
#LDFLAGS = ${LIBS}
# optimized
-CFLAGS = -std=c99 -pedantic -Wall -Wextra -Os ${CPPFLAGS}
+CFLAGS = -std=c99 -pedantic -Wall -Wextra -D_DEFAULT_SOURCE -Os ${CPPFLAGS}
LDFLAGS = -s ${LIBS}
# compiler and linker