summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorsin <sin@2f30.org>2014-07-29 12:44:02 +0100
committersin <sin@2f30.org>2014-07-29 12:45:39 +0100
commitd8501da4900ecd17a2eb9c83685e1c2eac7bfde6 (patch)
tree0cb2464785be5d6a8694f16628f86abfaa70f4fb /config.mk
parent3c79ee8c9bad9e08e8965832d8d930ff11d40cd6 (diff)
Don't bother to cleanup in error cases
These tools are "one-shot", nobody cares about memory leaks while the program is running. Bring back -Os, no more false positives because there's no interaction between gotos and setjmp/longjmp.
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/config.mk b/config.mk
index a34fe2d..b6af2cf 100644
--- a/config.mk
+++ b/config.mk
@@ -7,7 +7,7 @@ PREFIX = /usr/local
LIBS = -lpng
# flags
-CFLAGS = -std=c90 -ansi -pedantic -Wall -Wextra
+CFLAGS = -std=c90 -ansi -pedantic -Wall -Wextra -Os
LDFLAGS = -s ${LIBS}
# compiler and linker