summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--config.mk2
-rw-r--r--jpg2ff.c12
2 files changed, 7 insertions, 7 deletions
diff --git a/config.mk b/config.mk
index d8a62b3..4c48639 100644
--- a/config.mk
+++ b/config.mk
@@ -11,7 +11,7 @@ LIBS = -L${PNGLIB} -lpng -ljpeg
# flags
CPPFLAGS = -D_DEFAULT_SOURCE
-CFLAGS = -std=c99 -pedantic -Wall -Wextra -Os ${INCS} ${CPPFLAGS}
+CFLAGS = -std=c99 -pedantic -Wall -Wextra -Wno-clobbered -Os ${INCS} ${CPPFLAGS}
LDFLAGS = -s ${LIBS}
# compiler and linker
diff --git a/jpg2ff.c b/jpg2ff.c
index c6d8a02..f7ac5fc 100644
--- a/jpg2ff.c
+++ b/jpg2ff.c
@@ -17,7 +17,7 @@ static void
usage(void)
{
fprintf(stderr, "usage: %s\n", argv0);
- exit(EXIT_FAILURE);
+ exit(1);
}
METHODDEF(void)
@@ -37,9 +37,9 @@ main(int argc, char *argv[])
struct jpeg_decompress_struct cinfo;
struct jpeg_error_mgr jerr;
uint32_t width, height, val_be;
- uint16_t *ff_row = NULL;
+ uint16_t *ff_row;
size_t jpeg_row_len, ff_row_len, i, dx, sx;
- int status = EXIT_FAILURE;
+ int ret = 1;
JSAMPARRAY buffer; /* output row buffer */
argv0 = argv[0];
@@ -77,7 +77,7 @@ main(int argc, char *argv[])
ff_row_len = strlen("RRGGBBAA") * width;
if(!(ff_row = malloc(ff_row_len))) {
fprintf(stderr, "Can't malloc\n");
- return EXIT_FAILURE;
+ return 1;
}
/* write header with big endian width and height-values */
@@ -107,11 +107,11 @@ main(int argc, char *argv[])
}
}
jpeg_finish_decompress(&cinfo);
- status = EXIT_SUCCESS;
+ ret = 0;
cleanup:
free(ff_row);
jpeg_destroy_decompress(&cinfo);
- return status;
+ return ret;
}