summaryrefslogtreecommitdiff
path: root/debian/patches/debian-changes
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/debian-changes')
-rw-r--r--debian/patches/debian-changes17
1 files changed, 8 insertions, 9 deletions
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
index d5d5211..ecd925b 100644
--- a/debian/patches/debian-changes
+++ b/debian/patches/debian-changes
@@ -16,8 +16,8 @@ clone`.)
A single combined diff, containing all the changes, follows.
---- farbfeld-3.orig/2ff
-+++ farbfeld-3/2ff
+--- farbfeld-4.orig/2ff
++++ farbfeld-4/2ff
@@ -25,6 +25,12 @@ else
jpg2ff < "$TMP"
;;
@@ -31,16 +31,15 @@ A single combined diff, containing all the changes, follows.
convert "$TMP" png:- | png2ff
;;
esac
---- farbfeld-3.orig/config.mk
-+++ farbfeld-3/config.mk
-@@ -4,13 +4,13 @@ VERSION = 3
+--- farbfeld-4.orig/config.mk
++++ farbfeld-4/config.mk
+@@ -4,13 +4,13 @@ VERSION = 4
# Customize below to fit your system
# paths
-PREFIX = /usr/local
--MANPREFIX = ${PREFIX}/man
+PREFIX = /usr
-+MANPREFIX = ${PREFIX}/share/man
+ MANPREFIX = $(PREFIX)/share/man
# flags
-CPPFLAGS = -D_DEFAULT_SOURCE
@@ -49,6 +48,6 @@ A single combined diff, containing all the changes, follows.
+CPPFLAGS += -D_DEFAULT_SOURCE
+CFLAGS += -std=c99 -pedantic -Wall -Wextra -Os
+LDFLAGS += -s
- PNG-LDFLAGS = -lpng
- JPG-LDFLAGS = -ljpeg
+ PNG-LDLIBS = -lpng
+ JPG-LDLIBS = -ljpeg