summaryrefslogtreecommitdiff
path: root/debian/patches/respect-flags-passed-by-debhelper
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/respect-flags-passed-by-debhelper')
-rw-r--r--debian/patches/respect-flags-passed-by-debhelper23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/patches/respect-flags-passed-by-debhelper b/debian/patches/respect-flags-passed-by-debhelper
new file mode 100644
index 0000000..ee5fbc4
--- /dev/null
+++ b/debian/patches/respect-flags-passed-by-debhelper
@@ -0,0 +1,23 @@
+From: Dmitry Bogatov <KAction@gnu.org>
+Date: Thu, 12 Jan 2017 14:30:25 +0300
+X-Dgit-Generated: 2.20170109-1 3f2edacf422c4096bc36e172f72e0088a24cd2a3
+Subject: Respect FLAGS passed by debhelper
+
+
+---
+
+--- farbfeld-2.20170109.orig/config.mk
++++ farbfeld-2.20170109/config.mk
+@@ -17,9 +17,9 @@ INCS =
+ LIBS =
+
+ # flags
+-CPPFLAGS = -D_DEFAULT_SOURCE
+-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS}
+-LDFLAGS = -s ${LIBS}
++CPPFLAGS += -D_DEFAULT_SOURCE
++CFLAGS += -std=c99 -pedantic -Wall -Os ${INCS}
++LDFLAGS += -s ${LIBS}
+
+ # compiler and linker
+ CC = cc