summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrewsh@debian.org>2019-03-09 22:53:15 +0000
committerAndrej Shadura <andrewsh@debian.org>2019-03-09 22:53:15 +0000
commit84dc713d04237f6ebfc93f12180c12b5d8831618 (patch)
treeea7eaca30b9f9db8c6596bf2388be151d827789a
parentc32079c5744c3e04e8ad816060f8e1eb8d9c9d66 (diff)
Import Upstream version 20130704
-rw-r--r--ChangeLog4
-rw-r--r--configure.ac2
-rw-r--r--frontend/newparser/ParserDriver.cpp7
-rw-r--r--interpreter/icparser.y3
4 files changed, 11 insertions, 5 deletions
diff --git a/ChangeLog b/ChangeLog
index a100719..fa3b348 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2013/07/03 Stefan Potyra <sistpoty@ubuntu.com>:
+ * generic: Fix build failures with gcc-4.8, adapt to changes
+ for new bison version (cf. DBTS: #710626).
+
2012/06/05 Stefan Potyra <sistpoty@ubuntu.com>:
* interpreter: Consistently use memory allocator / deallocator
callbacks.
diff --git a/configure.ac b/configure.ac
index 8cc5dd8..b1a86e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
# $Id: configure.ac 5078 2010-12-17 14:25:10Z potyra $
-AC_INIT(fauhdlc, 20120707)
+AC_INIT(fauhdlc, 20130704)
# don't spam /
AC_CONFIG_AUX_DIR(scripts)
AM_INIT_AUTOMAKE
diff --git a/frontend/newparser/ParserDriver.cpp b/frontend/newparser/ParserDriver.cpp
index a03e259..34387cd 100644
--- a/frontend/newparser/ParserDriver.cpp
+++ b/frontend/newparser/ParserDriver.cpp
@@ -1,4 +1,4 @@
-/* $Id: ParserDriver.cpp 5081 2010-12-17 15:16:21Z potyra $
+/* $Id: ParserDriver.cpp 5117 2013-06-01 11:30:20Z potyra $
*
* ParserDriver: glue class to driver between scanner and parser.
*
@@ -105,7 +105,7 @@ ParserDriver::parse(const std::string& filename, const char* libName)
// set up scanner
this->scanner = new FAUhdlScanner(&inStream, &std::cout);
- FAUhdlParser parser = FAUhdlParser(*this);
+ FAUhdlParser *parser = new FAUhdlParser(*this);
this->currentFile = new std::string(filename);
this->currentLibrary = this->topNode->enterLibrary(libName);
@@ -118,7 +118,7 @@ ParserDriver::parse(const std::string& filename, const char* libName)
this->symbolTable.pushNewRegion();
// parse stuff
- parser.parse();
+ parser->parse();
// close stream again
inStream.close();
@@ -129,6 +129,7 @@ ParserDriver::parse(const std::string& filename, const char* libName)
this->symbolTable.popRegion();
// leave library region again
this->symbolTable.popRegion();
+ delete parser;
}
void
diff --git a/interpreter/icparser.y b/interpreter/icparser.y
index 39bfaeb..d7332d6 100644
--- a/interpreter/icparser.y
+++ b/interpreter/icparser.y
@@ -1,4 +1,4 @@
-/* $Id: icparser.y 4974 2010-10-18 17:10:52Z potyra $
+/* $Id: icparser.y 5118 2013-06-01 11:31:09Z potyra $
*
* Intermediate code interpreter.
*
@@ -18,6 +18,7 @@
%{
#include "basetypes.h"
#include <assert.h>
+#include <stdio.h>
#include "fauhdli_private.h"
#include "list.h"
%}