summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Gevers <elbrus@debian.org>2015-11-03 11:49:43 +0100
committerPaul Gevers <elbrus@debian.org>2015-11-03 17:00:16 +0100
commitb408f6213de337090b23882a68801bb79915df33 (patch)
treedd13693830b1cd4f25216990e78a6f456b3f38f2
parent37b9091352f12f0e1d5e66abca86d88ca784c0aa (diff)
Migrate to shorthand debhelper
-rw-r--r--debian/festlex-cmu.install3
-rwxr-xr-xdebian/rules34
2 files changed, 6 insertions, 31 deletions
diff --git a/debian/festlex-cmu.install b/debian/festlex-cmu.install
new file mode 100644
index 0000000..bf937d1
--- /dev/null
+++ b/debian/festlex-cmu.install
@@ -0,0 +1,3 @@
+lib/dicts/cmu/cmudict-*.out usr/share/festival/dicts/cmu
+lib/dicts/cmu/cmulex.scm usr/share/festival/dicts/cmu
+lib/dicts/cmu/cmu_lts_rules.scm usr/share/festival/dicts/cmu
diff --git a/debian/rules b/debian/rules
index 0f2d06f..3be9251 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,38 +1,10 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+%:
+ dh ${@}
+
build:
$(MAKE) -C lib/dicts/cmu
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- dh_clean
-
-# Build architecture-dependent files here.
-binary-arch: build
-# We have nothing to do by default.
-
-# Build architecture-independent files here.
-binary-indep: build
- dh_testdir
- dh_testroot
- dh_installdirs usr/share/festival/dicts/cmu
- cp lib/dicts/cmu/cmudict-*.out debian/tmp/usr/share/festival/dicts/cmu
- cp lib/dicts/cmu/cmulex.scm lib/dicts/cmu/cmu_lts_rules.scm \
- debian/tmp/usr/share/festival/dicts/cmu
- dh_installdocs
- dh_installchangelogs
- dh_compress
- dh_fixperms
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary