summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPaul Gevers <elbrus@debian.org>2015-11-03 21:37:29 +0100
committerPaul Gevers <elbrus@debian.org>2015-11-03 21:37:29 +0100
commitf28ba3aae52940012500a98cabb6652ef483c42e (patch)
tree758de790090e0b23ec44cbdd09d5fca53ffbd553 /debian/rules
parent9a89058a8d062fdcb56b569a1716ae96ddb6af3f (diff)
Migrate to shortstyle debhelper
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules32
1 files changed, 2 insertions, 30 deletions
diff --git a/debian/rules b/debian/rules
index 4ffd49d..91acefb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,35 +1,7 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-build:
-# Nothing to do.
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- dh_clean
-
-# Build architecture-dependent files here.
-binary-arch: build
-# We have nothing to do by default.
-
-# Build architecture-independent files here.
-binary-indep: build
- dh_testdir
- dh_testroot
- dh_installdirs usr/share/festival/dicts/
- cp lib/dicts/wsj.* debian/tmp/usr/share/festival/dicts/
- dh_installdocs
- dh_installchangelogs
- dh_compress
- dh_gencontrol
- dh_md5sums
- dh_fixperms
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+%:
+ dh ${@}