summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPaul Gevers <elbrus@debian.org>2015-11-04 22:02:43 +0100
committerPaul Gevers <elbrus@debian.org>2015-11-04 22:02:43 +0100
commit63dc0c3f641eafd2cfc56fe715ff0e2536c08c44 (patch)
treeea8147aef3fc45d99c7fab0c99864b7baf8b3951 /debian/rules
parent6c723fa08e4072421a0dfdb0f324f08cc0b1341e (diff)
Convert to shorthand debhelper
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules35
1 files changed, 2 insertions, 33 deletions
diff --git a/debian/rules b/debian/rules
index 6b7a130..91acefb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,38 +1,7 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-build:
-# Nothing to do.
-
-clean:
- dh_testdir
- dh_testroot
- dh_clean
-
-# Build architecture-dependent files here.
-binary-arch: build
-# We have nothing to do by default.
-
-# Build architecture-independent files here.
-binary-indep: build
- dh_testdir
- dh_testroot
- dh_installdirs usr/share/festival/voices/spanish/el_diphone/festvox \
- usr/share/festival/voices/spanish/el_diphone/group
- cp -a lib/voices/spanish/el_diphone/festvox/*.scm \
- debian/tmp/usr/share/festival/voices/spanish/el_diphone/festvox/
- cp -a lib/voices/spanish/el_diphone/group/*.group \
- debian/tmp/usr/share/festival/voices/spanish/el_diphone/group/
- dh_installdocs
- dh_installchangelogs
- dh_compress
- dh_fixperms
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+%:
+ dh ${@}