summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMatthias Urlichs <smurf@smurf.noris.de>2003-06-28 14:30:56 +0200
committerMatthias Urlichs <smurf@smurf.noris.de>2003-06-28 14:30:56 +0200
commit3e7895ec5ae81f7f1985650b47ae9c2c80159e9a (patch)
tree0341e6820ad1a2ec67b33e8e451839e7556eb1dd /debian/rules
festvox-ellpc11k (1.4.0-3) unstable; urgency=low
* depend on festival >= 1.4.3-9 (Migration to /usr/share). # imported from the archive
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules38
1 files changed, 38 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..6b7a130
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build:
+# Nothing to do.
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+# Build architecture-dependent files here.
+binary-arch: build
+# We have nothing to do by default.
+
+# Build architecture-independent files here.
+binary-indep: build
+ dh_testdir
+ dh_testroot
+ dh_installdirs usr/share/festival/voices/spanish/el_diphone/festvox \
+ usr/share/festival/voices/spanish/el_diphone/group
+ cp -a lib/voices/spanish/el_diphone/festvox/*.scm \
+ debian/tmp/usr/share/festival/voices/spanish/el_diphone/festvox/
+ cp -a lib/voices/spanish/el_diphone/group/*.group \
+ debian/tmp/usr/share/festival/voices/spanish/el_diphone/group/
+ dh_installdocs
+ dh_installchangelogs
+ dh_compress
+ dh_fixperms
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary