summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules41
1 files changed, 41 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8898da4
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,41 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+ORIGNAME=hy_fi_mv_diphone
+
+build:
+# Nothing to do.
+
+build-arch: build
+build-indep: build
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+# Build architecture-dependent files here.
+binary-arch: build
+# We have nothing to do.
+
+# Build architecture-independent files here.
+binary-indep: build
+ dh_testdir
+ dh_testroot
+ dh_installdirs usr/share/festival/voices/finnish/${ORIGNAME}/group
+ dh_install
+ dh_installdocs
+ dh_link usr/share/festival/voices/finnish/suopuhe.common \
+ usr/share/festival/voices/finnish/${ORIGNAME}/festvox
+ dh_installchangelogs
+ dh_compress
+ dh_fixperms
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary