summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Bogatov <KAction@gnu.org>2017-09-01 04:11:07 +0300
committerDmitry Bogatov <KAction@gnu.org>2018-02-14 19:27:54 +0300
commit469cd532d910496ef04fcd682505ecf6983d8aa2 (patch)
tree3e3cf0b8dbc99e8512eeae08606d76b43d6c0650
parentd409f1899d83788d23ee2de03aef58d8e870b033 (diff)
[PATCH] Disable binary stripping
-rw-r--r--Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 730a176..97ebf76 100644
--- a/Makefile
+++ b/Makefile
@@ -7,13 +7,12 @@ all: fgetty login login2 checkpassword
DIET=diet -Os
#CROSS=arm-linux-
CROSS=
-LDFLAGS=-s
+LDFLAGS=
%.o: %.c
# gcc -march=i386 -mcpu=i386 -pipe -Os -fomit-frame-pointer -I../dietlibc/include -c $^ -DTEST
$(DIET) $(CROSS)$(CC) -pipe -Os -fomit-frame-pointer -I../dietlibc/include -c $^ -DTEST
# gcc -march=i386 -mcpu=i386 -pipe -g -I../dietlibc/include -DTEST -c $^
- $(CROSS)strip -x -R .comment -R .note $@
%: %.o
$(DIET) $(CROSS)$(CC) -o $@ $^ $(LDFLAGS)