summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Bogatov <KAction@gnu.org>2017-09-01 04:11:07 +0300
committerDmitry Bogatov <KAction@debian.org>2019-01-07 20:35:25 +0000
commit31ec842874e021aec51d9e41995b4388eefbf736 (patch)
treed42fcbcc8dfbec9a94e8e9da554615e14eff0d9f
parent3242eeb824e521deff5215af38a373b0ffaade99 (diff)
[PATCH] Fix manpage installation
Install manpage under /usr/share/man, not /usr/man. It fixes lintian error. Gbp-Pq: Name patch-fix-manpage-installation.patch
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 97ebf76..df32647 100644
--- a/Makefile
+++ b/Makefile
@@ -29,12 +29,12 @@ debug: fgetty.c fmt_ulong.o
gcc -g -o debug fgetty.c fmt_ulong.o -DDEBUG
install:
- install -d $(DESTDIR)/bin $(DESTDIR)/sbin $(DESTDIR)/usr/man/man8
+ install -d $(DESTDIR)/bin $(DESTDIR)/sbin $(DESTDIR)/usr/share/man/man8
install login $(DESTDIR)/bin/login1
install login2 $(DESTDIR)/bin
install fgetty $(DESTDIR)/sbin
install checkpassword $(DESTDIR)/bin/checkpassword.login
- install -m 644 fgetty.8 $(DESTDIR)/usr/man/man8/fgetty.8
+ install -m 644 fgetty.8 $(DESTDIR)/usr/share/man/man8/fgetty.8
@echo "now change your /etc/inittab to do something like"
@echo " 1:123:respawn:/sbin/fgetty /dev/vc/1 --noclear"