summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 730a176..97ebf76 100644
--- a/Makefile
+++ b/Makefile
@@ -7,13 +7,12 @@ all: fgetty login login2 checkpassword
DIET=diet -Os
#CROSS=arm-linux-
CROSS=
-LDFLAGS=-s
+LDFLAGS=
%.o: %.c
# gcc -march=i386 -mcpu=i386 -pipe -Os -fomit-frame-pointer -I../dietlibc/include -c $^ -DTEST
$(DIET) $(CROSS)$(CC) -pipe -Os -fomit-frame-pointer -I../dietlibc/include -c $^ -DTEST
# gcc -march=i386 -mcpu=i386 -pipe -g -I../dietlibc/include -DTEST -c $^
- $(CROSS)strip -x -R .comment -R .note $@
%: %.o
$(DIET) $(CROSS)$(CC) -o $@ $^ $(LDFLAGS)