summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2017-09-04 10:47:33 +0800
committerWill Estes <westes575@gmail.com>2017-09-04 11:22:30 -0400
commit24fd0551333e7eded87b64dd36062da3df2f6380 (patch)
treef02e0bf9e3899e7c089bdf4d0439cba352d5d735
parent1d62d3eb24d06030ae2641fe4670de3a8da9e67e (diff)
build: AC_USE_SYSTEM_EXTENSIONS in configure.ac.
This would, e.g. define _GNU_SOURCE in config.h, enabling the reallocarray() prototype in glibc 2.26+ on Linux systems with that version of glibc. Fixes #241.
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c6f12d6..3c977a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,8 +25,10 @@
# autoconf requirements and initialization
AC_INIT([the fast lexical analyser generator],[2.6.4],[flex-help@lists.sourceforge.net],[flex])
+AC_PREREQ([2.60])
AC_CONFIG_SRCDIR([src/scan.l])
AC_CONFIG_AUX_DIR([build-aux])
+AC_USE_SYSTEM_EXTENSIONS
LT_INIT
AM_INIT_AUTOMAKE([1.15 -Wno-portability foreign std-options dist-lzip parallel-tests subdir-objects])
AC_CONFIG_HEADER([src/config.h])