summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-04 14:52:16 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:26 -0500
commit53d5bc8876095c0973b540a737f37fa021e10fe1 (patch)
tree35e8beff7378bea7b323302bc1b34510837aa69a
parent6e57bbebe71ece2df8811576bc2e148f40d09b34 (diff)
upgrade automake version to 1.14.1
Unfortunately, automake 1.14.1 does not play nicely with AC_CONFIG_AUX_DIR, so upgrading the used automake version required removing the build-aux directory and letting autoconf's installed helper files live more over the tree.
-rw-r--r--.gitignore11
-rw-r--r--configure.ac3
2 files changed, 11 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index 9bd9266..0914198 100644
--- a/.gitignore
+++ b/.gitignore
@@ -13,7 +13,6 @@ Makefile
Makefile.in
aclocal.m4
autom4te.cache
-build-aux
config.log
config.status
configure
@@ -21,3 +20,13 @@ flex-*/
libtool
mkinstalldirs
stamp-*
+compile
+config.guess
+config.rpath
+config.sub
+depcomp
+install-sh
+ltmain.sh
+missing
+test-driver
+ylwrap
diff --git a/configure.ac b/configure.ac
index 5e4c572..4edc904 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,8 +30,7 @@ LT_INIT
SHARED_VERSION_INFO="2:0:0"
AC_SUBST(SHARED_VERSION_INFO)
AC_CONFIG_SRCDIR([src/scan.l])
-AC_CONFIG_AUX_DIR([build-aux])
-AM_INIT_AUTOMAKE([gnu check-news std-options dist-bzip2 dist-xz parallel-tests 1.10])
+AM_INIT_AUTOMAKE([gnu check-news std-options dist-bzip2 dist-xz parallel-tests 1.14.1])
AC_CONFIG_HEADER([src/config.h])
AC_CONFIG_LIBOBJ_DIR([lib])
AC_CONFIG_MACRO_DIR([m4])