summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-25 18:12:28 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-25 18:12:28 -0800
commit5aa8fc45ae3799ae8becddcf2ef48d5b68f62d1b (patch)
treee26897f35efbe5d6714331e82b794fd24486247d
parent45bace6d30eebcc9e3f0a5eae7ea5cad93357831 (diff)
revert previous changesdebian/2.6.0-3
Signed-off-by: Manoj Srivastava <srivasta@debian.org>
-rw-r--r--Makefile.am2
-rw-r--r--configure.ac6
-rw-r--r--debian/changelog7
-rw-r--r--doc/Makefile.am2
4 files changed, 9 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 86a894f..076ccad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,7 +53,7 @@ SUBDIRS = \
doc \
examples \
po \
- tests \
+ tests \
tools
# Create the ChangeLog, but only if we're inside a git working directory
diff --git a/configure.ac b/configure.ac
index 4af4a1b..4c519dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,12 +51,6 @@ AC_PROG_INSTALL
AC_PATH_PROG(BISON, bison,bison)
AC_PATH_PROG(HELP2MAN, help2man, help2man)
-if test "$cross_compiling" = yes; then
-FLEXexe='flex$(EXEEXT)'
-else
-FLEXexe='$(top_builddir)/flex$(EXEEXT)'
-fi
-AC_SUBST(FLEXexe)
# Check for a m4 that supports -P
diff --git a/debian/changelog b/debian/changelog
index d3de4c7..d8d232b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+flex (2.6.0-3) unstable; urgency=low
+
+ * Revert the help2man fix; it was creating errors in the diff.gz
+ file. We are now back to being mostly in sync with upstream.
+
+ -- Manoj Srivastava <srivasta@debian.org> Mon, 25 Jan 2016 18:12:03 -0800
+
flex (2.6.0-2) unstable; urgency=low
* Revert "[fix-off-by-one-error]: generatred line numbers are off by
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 9751198..e776c18 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -27,5 +27,5 @@ $(dist_man_MANS): $(top_srcdir)/configure.ac $(top_srcdir)/src/flex.skl $(top_sr
for i in $(dist_man_MANS) ; do \
$(help2man) --name='$(PACKAGE_NAME)' \
--section=`echo $$i | sed -e 's/.*\.\([^.]*\)$$/\1/'` \
- $(FLEXexe) > $$i || rm -f $$i ; \
+ $(top_srcdir)/src/flex$(EXEEXT) > $$i || rm -f $$i ; \
done