summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-02-18 14:34:20 -0500
committerWill Estes <westes575@gmail.com>2014-02-18 14:34:20 -0500
commit5dbce367dca7bfd96ef347286cecb34cb71bf7d5 (patch)
tree1f0f0548d899e68bb016abbc7f54fe577ddcc100
parente43ca6dd7e94e5a6e835dc47074b5d88c20f7c99 (diff)
move m4 make variable to src/Makefile.am.
This prevents an error when building skel.c caused by the $(m4) make variable not being defined. Particularly nasty since skel.c would still be created, thus causing make to think skel.c was up to date.
-rw-r--r--Makefile.am1
-rw-r--r--src/Makefile.am2
2 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e517a0f..076ccad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,7 +34,6 @@
# additional info.
ACLOCAL_AMFLAGS = -I m4
-m4 = @M4@
indent = @INDENT@
dist_doc_DATA = \
diff --git a/src/Makefile.am b/src/Makefile.am
index 9cd7960..5353ebb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,6 +3,8 @@ localedir = $(datadir)/locale
AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl
LIBS = @LIBINTL@ @LIBS@
+m4 = @M4@
+
bin_PROGRAMS = flex
lib_LTLIBRARIES = \
libfl.la \