summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@golden-gryphon.com>2014-05-26 18:13:23 -0700
committerManoj Srivastava <srivasta@golden-gryphon.com>2014-05-26 18:13:23 -0700
commitcf22f02ecc6f7b2cca999316732b63b7f91bc8f3 (patch)
tree3f14efb1a5519b47810532c0945c6cd99df847e2
parentafcf3658e0b979a1bd7a3d54e9581f0c627a3d3f (diff)
[master]: Clean up rules and dependencies
* dh-autoreconf already depends on all the autotools that it will attempt to use to rebuild the package's build framework, so remove the direct (and redundant) dependencies on the autotools packages. Suggestion by Peter Pentchev (Closes: #749341). * The patch also cleaned up the creation of examples and links for man pages. Signed-off-by: Manoj Srivastava <srivasta@golden-gryphon.com>
-rw-r--r--debian/changelog13
-rw-r--r--debian/control3
-rw-r--r--debian/flex.examples7
-rwxr-xr-xdebian/rules17
4 files changed, 23 insertions, 17 deletions
diff --git a/debian/changelog b/debian/changelog
index dc168ff..99fa81b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+flex (2.5.39-7) unstable; urgency=low
+
+ * dh-autoreconf already depends on all the autotools that it will
+ attempt to use to rebuild the package's build framework, so remove the
+ direct (and redundant) dependencies on the autotools
+ packages. Suggestion by Peter Pentchev (Closes: #749341).
+ * The patch also cleaned up the creation of examples and links for man
+ pages.
+ * Bug fix #749341: "Drop the autotools build dependencies, dh-autoreconf
+ is sufficient", thanks to Peter Pentchev
+
+ -- Manoj Srivastava <srivasta@debian.org> Mon, 26 May 2014 18:12:36 -0700
+
flex (2.5.39-6) unstable; urgency=low
* The code that is generated by flex has an off-by-one error in the
diff --git a/debian/control b/debian/control
index 09a99d4..fe447c5 100644
--- a/debian/control
+++ b/debian/control
@@ -5,8 +5,7 @@ Section: devel
Homepage: http://flex.sf.net/
Priority: optional
Build-Depends: bison, gettext, texinfo, help2man, file, po-debconf,
- debhelper (>= 9.0.0), dh-autoreconf, autoconf,
- automake | automaken, autopoint, texlive-latex-base,
+ debhelper (>= 9.0.0), dh-autoreconf, texlive-latex-base,
texlive-fonts-recommended, dpkg-dev (>= 1.16.0)
Maintainer: Manoj Srivastava <srivasta@debian.org>
Standards-Version: 3.9.5
diff --git a/debian/flex.examples b/debian/flex.examples
index d838da9..e07855f 100644
--- a/debian/flex.examples
+++ b/debian/flex.examples
@@ -1 +1,6 @@
-examples/
+examples/debflex.awk
+examples/fastwc/
+examples/Makefile.am
+examples/manual/
+examples/README
+examples/testxxLexer.l
diff --git a/debian/rules b/debian/rules
index 514b19e..a27811c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -49,6 +49,9 @@ ifneq (,$(filter libfl-dev, $(shell dh_listpackages)))
debian/libfl.shared_object > debian/libfl-dev/usr/lib/$(DEB_HOST_MULTIARCH)/libfl.so
ln -s libfl.a debian/libfl-dev/usr/lib/$(DEB_HOST_MULTIARCH)/libl.a
endif
+ifneq (,$(filter flex, $(shell dh_listpackages)))
+ test ! -f debian/flex/usr/share/doc/flex/COPYING || rm -f debian/flex/usr/share/doc/flex/COPYING
+endif
dh_link
@@ -58,15 +61,6 @@ ifneq (,$(filter flex-doc, $(shell dh_listpackages)))
mv debian/flex-doc/usr/share/doc/flex-doc/flex.html debian/flex-doc/usr/share/doc/flex-doc/html
endif
-override_dh_installexamples:
- dh_installexamples
-ifneq (,$(filter flex, $(shell dh_listpackages)))
- mv debian/flex/usr/share/doc/flex/examples/examples debian/flex/usr/share/doc/flex/tmp
- rmdir debian/flex/usr/share/doc/flex/examples
- mv debian/flex/usr/share/doc/flex/tmp debian/flex/usr/share/doc/flex/examples
- test ! -f debian/flex/usr/share/doc/flex/COPYING || rm -f debian/flex/usr/share/doc/flex/COPYING
-endif
-
override_dh_auto_build:
dh_auto_build
$(MAKE) -C doc flex.info flex.html
@@ -75,11 +69,6 @@ override_dh_auto_build:
bash -n debian/flex.postinst
bash -n debian/flex.prerm
-override_dh_installman:
- dh_installman
- dh_link usr/share/man/man1/flex.1 usr/share/man/man1/flex++.1
- dh_link usr/share/man/man1/flex.1 usr/share/man/man1/lex.1
-
#Local variables:
#mode: makefile
#End: