summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2018-02-16 12:45:46 -0800
committerManoj Srivastava <srivasta@debian.org>2018-02-16 12:45:46 -0800
commitf808e335dec3ae4048f08421a69a7c64b8501576 (patch)
tree7be8efb0b1ed25983ea178f6b32dfcf8fa3c7442
parentf67d0e7476b4c9ecfda3f311ba8d46659f5b2727 (diff)
[master]: Fix a couple of FTBS bugsdebian/2.6.4-4archive/debian/2.6.4-4
Signed-off-by: Manoj Srivastava <srivasta@debian.org>
-rw-r--r--debian/changelog9
-rwxr-xr-xdebian/rules9
-rw-r--r--src/flex.skl2
3 files changed, 17 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index d6e43f0..732db27 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+flex (2.6.4-4) unstable; urgency=medium
+
+ * remove .la file from flex; fixed FTBS for PAM
+ * Bug fix: "backported commit causes FTBFS (and potentially
+ miscompilation) of generated files", thanks to Adrian Bunk (Closes:
+ #890411).
+
+ -- Manoj Srivastava <srivasta@debian.org> Fri, 16 Feb 2018 12:45:26 -0800
+
flex (2.6.4-3) unstable; urgency=medium
* Bug fix: "Debian-specific libfl.so linker script causes FTBFS", thanks
diff --git a/debian/rules b/debian/rules
index 6b82df1..1586979 100755
--- a/debian/rules
+++ b/debian/rules
@@ -50,10 +50,14 @@ override_dh_auto_configure:
sed -i -e 's/^dist_doc_DATA[[:space:]]*=.*/dist_doc_DATA=/' doc/Makefile
override_dh_install:
+ test ! -d debian/tmp/lib/$(DEB_HOST_MULTIARCH) || \
+ find debian/tmp/lib/$(DEB_HOST_MULTIARCH) -type f \
+ -name \*.la -exec rm {} \;
dh_install
rm -f debian/flex/usr/share/doc/flex/flex.pdf
ifneq (,$(filter flex, $(shell dh_listpackages)))
- test ! -f debian/flex/usr/share/doc/flex/COPYING || rm -f debian/flex/usr/share/doc/flex/COPYING
+ test ! -f debian/flex/usr/share/doc/flex/COPYING || \
+ rm -f debian/flex/usr/share/doc/flex/COPYING
endif
dh_link
@@ -61,7 +65,8 @@ endif
override_dh_installdocs:
dh_installdocs
ifneq (,$(filter flex-doc, $(shell dh_listpackages)))
- mv debian/flex-doc/usr/share/doc/flex-doc/flex.html debian/flex-doc/usr/share/doc/flex-doc/html
+ mv debian/flex-doc/usr/share/doc/flex-doc/flex.html \
+ debian/flex-doc/usr/share/doc/flex-doc/html
endif
override_dh_auto_build:
diff --git a/src/flex.skl b/src/flex.skl
index f2da3a3..aae5560 100644
--- a/src/flex.skl
+++ b/src/flex.skl
@@ -221,7 +221,7 @@ m4_ifdef( [[M4_YY_TABLES_EXTERNAL]],
m4_ifdef( [[M4_YY_ALWAYS_INTERACTIVE]], ,
[[m4_ifdef( [[M4_YY_NEVER_INTERACTIVE]], ,
[[#ifndef _POSIX_C_SOURCE
-#define _POSIX_C_SOURCE 1 /* for fileno() */
+#define _POSIX_C_SOURCE 200809 /* for fileno() */
#ifndef _POSIX_SOURCE
#define _POSIX_SOURCE 1
#endif