summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Millaway <john43@users.sourceforge.net>2002-03-28 19:52:33 +0000
committerJohn Millaway <john43@users.sourceforge.net>2002-03-28 19:52:33 +0000
commit712c03b38fb35f9d7f16e0fdd27441c3efda0071 (patch)
tree08ff0511d9f7e87cd0b0062239cbcd4f2e44c963
parentf9365ab47fde213a761f90a5a0cc6437a4f30968 (diff)
Output of `flex --version` now matches GNU coding standards.
Makefile.am now uses `help2man` to generate flex.1
-rw-r--r--Makefile.am7
-rw-r--r--main.c11
2 files changed, 13 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 8975079..febfdf7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,6 +79,7 @@ include_HEADERS = \
FlexLexer.h
info_TEXINFOS = flex.texi
+man1_MANS = flex.1
EXTRA_DIST = \
AUTHORS \
@@ -95,7 +96,8 @@ EXTRA_DIST = \
mkskel.sh \
ABOUT-NLS \
config.rpath \
- gettext.h
+ gettext.h \
+ flex.1
BUILT_SOURCES = \
skel.c \
@@ -120,6 +122,9 @@ yylex.o: yylex.c parse.h flexdef.h config.h
skel.c: flex.skl mkskel.sh
$(SHELL) $(srcdir)/mkskel.sh $(srcdir)/flex.skl >skel.c
+flex.1: flex
+ help2man --name='fast lexical analyzer generator' --section=1 ./flex >flex.1
+
main.o: main.c flexdef.h config.h version.h
ccl.o: ccl.c flexdef.h config.h
dfa.o: dfa.c flexdef.h config.h
diff --git a/main.c b/main.c
index b679d4d..28c91b7 100644
--- a/main.c
+++ b/main.c
@@ -1115,7 +1115,7 @@ char **argv;
break;
case OPT_VERSION:
- printf( _( "%s version %s\n" ),
+ printf( _( "%s %s\n" ),
program_name, flex_version );
exit( 0 );
@@ -1673,10 +1673,12 @@ void usage()
outfilename = outfile_path;
}
- fprintf(f,_( "%s [OPTIONS...] [file...]\n"), program_name);
+ fprintf(f,_( "Usage: %s [OPTIONS] [FILE]...\n"), program_name);
fprintf(f,
_(
-"Table Compression: (default is -Cem)\n"
+"Generates programs that perform pattern-matching on text.\n"
+"\n"
+"Table Compression:\n"
" -Ca, --align trade off larger tables for better memory alignment\n"
" -Ce, --ecs construct equivalence classes\n"
" -Cf do not compress tables; use -f representation\n"
@@ -1685,7 +1687,8 @@ _(
" -Cr, --read use read() instead of stdio for scanner input\n"
" -f, --full generate fast, large scanner. Same as -Cfr\n"
" -F, --fast use alternate table representation. Same as -CFr\n"
-
+" -Cem default compression (same as --ecs --meta-ecs)\n"
+
"\n"
"Debugging:\n"
" -d, --debug enable debug mode in scanner\n"