summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2002-03-06 16:32:59 +0000
committerWill Estes <wlestes@users.sourceforge.net>2002-03-06 16:32:59 +0000
commit88f5ad03328408b8ac39b144b787b50baf023a1f (patch)
treedc214ba940d4283447ed96caf7658b40f4413a86
parent4b33148cf36cc554910a360873318d2dd1fdce4a (diff)
remove subdirectories from EXTRA_DIST; add a SUBDIRS macro to handle examples/; clean up the dist-hook target
-rw-r--r--Makefile.am16
1 files changed, 6 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index b9f0b4b..a9c8079 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -91,16 +91,16 @@ EXTRA_DIST = \
TODO \
autogen.sh \
flex.skl \
- mkskel.sh \
- tests \
- to.do \
- examples \
- faqs
+ mkskel.sh
+
BUILT_SOURCES = \
skel.c \
parse.c \
-scan.c
+ scan.c
+
+SUBDIRS = \
+ examples
# We have a few dependencies and rules to enumerate. (from the old
# Makefile.in by Vern)
@@ -134,7 +134,3 @@ ChangeLog:
.PHONY: ChangeLog
dist-hook:
- -if test ! "x$(distdir)" = "x" ; then \
- rm -rf `find $(distdir)/ -name CVS` ;\
- fi;
- -cd $(PACKAGE)-$(VERSION) && ./autogen.sh