summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-02-18 12:28:53 -0800
committerManoj Srivastava <srivasta@debian.org>2016-02-18 12:28:53 -0800
commit2b224d69173533b8703ad9724245ea93f0007a68 (patch)
treef7ae242685f14fb63d2870d923b98cc8f7a4c4ac
parent45b7ac5a5a43bd4c4d7ce0ecefc5fdbcd4d1b473 (diff)
Updated for cross compilation supportdebian/2.6.0-9
Updated standards version to 3.9.7. No changes needed. Bug fix: "[src:flex] FTCBFS: runs host arch binaries during build", thanks to Helmut Grohne. Make the tests use either the installed flex or the newly built flex to generate test soureces, depending on whether or not we are cross compiling. Also added a build depends flex <cross> Hope this works. This has not broken the common case. (Closes: #762180). Signed-off-by: Manoj Srivastava <srivasta@debian.org>
-rw-r--r--debian/changelog11
-rw-r--r--debian/control5
-rw-r--r--tests/Makefile.am2
3 files changed, 15 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 6e33eee..900abd3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+flex (2.6.0-9) unstable; urgency=low
+
+ * Updated standards version to 3.9.7. No changes needed.
+ * Bug fix: "[src:flex] FTCBFS: runs host arch binaries during build",
+ thanks to Helmut Grohne. Make the tests use either the installed flex
+ or the newly built flex to generate test soureces, depending on
+ whether or not we are cross compiling. Also added a build depends flex <cross>
+ Hope this works. This has not broken the common case. (Closes: #762180).
+
+ -- Manoj Srivastava <srivasta@debian.org> Thu, 18 Feb 2016 12:26:17 -0800
+
flex (2.6.0-8) unstable; urgency=low
* Bug fix: "flex FTCBFS: runs tests even when DEB_BUILD_OPTIONS contains
diff --git a/debian/control b/debian/control
index e6d3967..b340606 100644
--- a/debian/control
+++ b/debian/control
@@ -5,10 +5,11 @@ Section: devel
Homepage: http://flex.sf.net/
Priority: optional
Build-Depends: bison, gettext, texinfo, help2man, file, po-debconf,
- debhelper (>= 9.0.0), dh-autoreconf, dpkg-dev (>= 1.16.0)
+ debhelper (>= 9.0.0), dh-autoreconf, dpkg-dev (>= 1.16.0),
+ flex <cross>
Build-Depends-Indep: texlive-latex-base, texlive-fonts-recommended, cm-super-minimal
Maintainer: Manoj Srivastava <srivasta@debian.org>
-Standards-Version: 3.9.6
+Standards-Version: 3.9.7
Package: flex
Architecture: any
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0c51570..bdcec1d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -336,7 +336,7 @@ pthread_pthread_LDADD = -lpthread
# specify how to process .l files in order to test the flex built by make all
-FLEX = $(top_builddir)/src/flex
+FLEX = $(FLEXexe)
.l.c: $(FLEX)
$(FLEX) -o $@ $<