summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-02-16 21:32:58 -0800
committerManoj Srivastava <srivasta@debian.org>2016-02-16 21:36:33 -0800
commit36c1f588910ed0d016a8691949ff4228e5019479 (patch)
tree79a60252800ff29f7fcf5e58f8ec2e45ebb9c7a5
parentfc3bef615d90e17613dc8264d7bd99083f8d7de5 (diff)
Honour nockeck in DEB_BUILD_OPTIONS
Bug fix: "flex FTCBFS: runs tests even when DEB_BUILD_OPTIONS contains nocheck", thanks to Helmut Grohne. Added an AM_CONDITIONAL that tests DEB_BUILD_OPTIONS in configure.ac, and use that in tests/Makefile.am. Seems to work fine. (Closes: #812659). Signed-off-by: Manoj Srivastava <srivasta@debian.org>
-rw-r--r--configure.ac3
-rw-r--r--debian/changelog9
-rw-r--r--tests/Makefile.am6
3 files changed, 17 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4c519dc..ae2c0d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,9 @@ AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_CHECK_FUNCS([dup2 isascii memset pow regcomp setlocale strchr strtol])
+# are we ignoring tests
+AM_CONDITIONAL([SKIP_TEST], [ "$(echo $DEB_BUILD_OPTIONS | grep nocheck)" ])
+
AC_CONFIG_FILES(
Makefile
doc/Makefile
diff --git a/debian/changelog b/debian/changelog
index 6d92c6a..3d97fa7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+flex (2.6.0-8) unstable; urgency=low
+
+ * Bug fix: "flex FTCBFS: runs tests even when DEB_BUILD_OPTIONS contains
+ nocheck", thanks to Helmut Grohne. Added an AM_CONDITIONAL that tests
+ DEB_BUILD_OPTIONS in configure.ac, and use that in
+ tests/Makefile.am. Seems to work fine. (Closes: #812659).
+
+ -- Manoj Srivastava <srivasta@debian.org> Tue, 16 Feb 2016 21:32:42 -0800
+
flex (2.6.0-7) unstable; urgency=low
* Bug fix: "C++ style comment in C output", thanks to Tim Rühsen
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4ac3c17..0c51570 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -19,7 +19,11 @@
# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
# PURPOSE.
-TESTS = $(check_PROGRAMS) options.cn
+if SKIP_TEST
+ TESTS = options.cn
+else !SKIP_TEST
+ TESTS = $(check_PROGRAMS) options.cn
+endif !SKIP_TEST
# The script testwrapper.sh will run most tests as is. A couple tests
# in the suite end in .reject, .table and the like so that we can pass