summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-11-16 16:32:59 -0500
committerWill Estes <westes575@gmail.com>2014-11-16 16:32:59 -0500
commit6b2c215cd71bb2fd919191fd1570e4a223694616 (patch)
treede09420a7f1640bf93e49178a9e5c91fbb8e95ee
parent39413323dda9e00a2c1d2a22ddf3d12b35d9a4ad (diff)
remove unused files after test suite refactor
-rw-r--r--tests/TEMPLATE/.gitignore8
-rw-r--r--tests/TEMPLATE/Makefile.am50
-rw-r--r--tests/TEMPLATE/cvsignore4
-rw-r--r--tests/TEMPLATE/parser.y61
-rw-r--r--tests/TEMPLATE/scanner.l54
-rw-r--r--tests/TEMPLATE/test.input2
-rwxr-xr-xtests/create-test33
-rw-r--r--tests/descriptions49
8 files changed, 0 insertions, 261 deletions
diff --git a/tests/TEMPLATE/.gitignore b/tests/TEMPLATE/.gitignore
deleted file mode 100644
index 699370b..0000000
--- a/tests/TEMPLATE/.gitignore
+++ /dev/null
@@ -1,8 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-TEMPLATE
-OUTPUT
-.deps
diff --git a/tests/TEMPLATE/Makefile.am b/tests/TEMPLATE/Makefile.am
deleted file mode 100644
index 531d931..0000000
--- a/tests/TEMPLATE/Makefile.am
+++ /dev/null
@@ -1,50 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-FLEX = $(top_builddir)/flex
-
-builddir = @builddir@
-
-EXTRA_DIST = scanner.l parser.y test.input
-CLEANFILES = scanner.c scanner.h parser.c parser.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o # parser.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(builddir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-#LFLAGS = --header="scanner.h"
-#YFLAGS = --defines --output=parser.c
-
-testname = TEMPLATE
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-parser.c: $(srcdir)/parser.y
- $(BISON) $(YFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
diff --git a/tests/TEMPLATE/cvsignore b/tests/TEMPLATE/cvsignore
deleted file mode 100644
index 5726ff9..0000000
--- a/tests/TEMPLATE/cvsignore
+++ /dev/null
@@ -1,4 +0,0 @@
-Makefile
-parser.c
-parser.h
-scanner.c
diff --git a/tests/TEMPLATE/parser.y b/tests/TEMPLATE/parser.y
deleted file mode 100644
index 54c428b..0000000
--- a/tests/TEMPLATE/parser.y
+++ /dev/null
@@ -1,61 +0,0 @@
-/*
- * This file is part of flex.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- *
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * Neither the name of the University nor the names of its contributors
- * may be used to endorse or promote products derived from this software
- * without specific prior written permission.
- *
- * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
- * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
- * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE.
- */
-
-/* A dummy template parser to build "parser.c" and "parser.h".
- How to compile:
- bison --defines --output-file="parser.c" --name-prefix="test" parser.y
- */
-%{
-#include <stdio.h>
-#include <stdlib.h>
-#include "config.h"
-
-#define YYERROR_VERBOSE 1 /* For debugging. */
-/* #define YYPARSE_PARAM scanner */ /* For pure bison parser. */
-/* #define YYLEX_PARAM scanner */ /* For reentrant flex. */
-
-
-int yyerror(char* msg);
-extern int testlex();
-
-%}
-
-%%
-
-rule: ;
-
-%%
-
-int yyerror(char* msg) {
- fprintf(stderr,"%s\n",msg);
- return 0;
-}
-
-/*
-int
-main ( int argc, char** argv )
-{
- yyparse ();
- return 0;
-}
-*/
diff --git a/tests/TEMPLATE/scanner.l b/tests/TEMPLATE/scanner.l
deleted file mode 100644
index c41a778..0000000
--- a/tests/TEMPLATE/scanner.l
+++ /dev/null
@@ -1,54 +0,0 @@
-/*
- * This file is part of flex.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- *
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * Neither the name of the University nor the names of its contributors
- * may be used to endorse or promote products derived from this software
- * without specific prior written permission.
- *
- * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
- * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
- * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE.
- */
-
-%{
-/* A template scanner file to build "scanner.c". */
-#include <stdio.h>
-#include <stdlib.h>
-#include "config.h"
-/*#include "parser.h" */
-
-%}
-
-%option 8bit outfile="scanner.c" prefix="test"
-%option nounput nomain noyywrap
-%option warn
-
-
-%%
-
-. { }
-
-%%
-
-int main(void);
-
-int
-main ()
-{
- yyin = stdin;
- yyout = stdout;
- yylex();
- printf("TEST RETURNING OK.\n");
- return 0;
-}
diff --git a/tests/TEMPLATE/test.input b/tests/TEMPLATE/test.input
deleted file mode 100644
index 7288a40..0000000
--- a/tests/TEMPLATE/test.input
+++ /dev/null
@@ -1,2 +0,0 @@
-0000 foo 1111 foo 0000 bar
-0000 foo 1111 foo 0000 bar
diff --git a/tests/create-test b/tests/create-test
deleted file mode 100755
index 05e6864..0000000
--- a/tests/create-test
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/sh
-
-TESTFILES="Makefile.am scanner.l parser.y .cvsignore test.input"
-
-if [ ! $# -eq 1 ] ; then
- echo 1>&2 Usage: $0 test-name
- exit 1
-fi
-
-if test -e "$1" ; then
- echo 1>&2 "$1 exists already"
- exit 1
-fi
-
-mkdir $1
-if test "$?" -ne 0 ; then
- echo 1>&2 "mkdir $1 failed"
- exit 1
-fi
-
-for i in $TESTFILES ; do
- cp TEMPLATE/$i $1/$i
-done
-
-echo "$1" >> "$1"/.cvsignore
-
-sed -i '/--new-test-here--/i\
-tests/'"$1"'/Makefile' ../configure.in
-
-sed -i '/^\(DIST_\)\?SUBDIRS/a\
- '"$1"' \\' Makefile.am
-
-sed -i "s:TEMPLATE:$1:g" "$1"/Makefile.am
diff --git a/tests/descriptions b/tests/descriptions
deleted file mode 100644
index 57b4885..0000000
--- a/tests/descriptions
+++ /dev/null
@@ -1,49 +0,0 @@
-DESCRIPTION OF TESTS
-
-TEMPLATE - A NO-OP skeleton scanner.
-array-nr - Use %option array, non-reentrant.
-array-r - Use %option array, reentrant.
-basic-nr - Simple scanner, non-reentrant.
-basic-r - Simple scanner, reentrant.
-bison-nr - Ordinary bison-bridge.
-bison-yylloc - Reentrant scanner + pure parser. Requires bison.
-bison-yylval - Reentrant scanner + pure parser. Requires bison.
-ccl - Character classes.
-c-cpp-nr - Compile a C scanner with C++ compiler, nonreentrant.
-c-cpp-r - Compile a C scanner with C++ compiler, reentrant.
-c++-basic - The C++ scanner.
-c++-multiple-scanners - Multiple C++ scanners.
-debug-nr - Use yy_flex_debug, non-reentrant.
-debug-r - Use debugging functions, reentrant.
-extended - Extended pattern syntax.
-header-nr - Test generated header file, non-reentrant.
-header-r - Test generated header file, reentrant.
-include-by-buffer - YY_BUFFER_STATE, yy_push_state, etc.
-include-by-push - yypush_buffer_state, yypop_buffer_state
-include-by-reentrant - Nested scanners.
-linedir-r - Check #line directives.
-lineno-nr - Use %option yylineno, non-reentrant.
-lineno-r - Use %option yylineno, reentrant.
-mem-nr - Override memory api, non-reentrant.
-mem-r - Override memory api, reentrant.
-multiple-scanners-nr - #include and run two separate scanners, non-reentrant.
-multiple-scanners-r - #include and run two separate scanners, reentrant.
-noansi-nr - test %option noansi-*, non-reentrant.
-noansi-r - test %option noansi-*, reentrant.
-posix - Test %option posix-compat.
-posixly-correct - Test POSIXLY_CORRECT variable.
-prefix-nr - Verify prefixes are working, nonreentrant.
-prefix-r - Verify prefixes are working, reentrant.
-pthread - Pthreads test. A NO-OP if libpthread not found.
-quotes - Verify user code is not mangled by m4.
-reject - Check REJECT code.
-rescan-nr - Reuse same scanner several times, nonreentrant.
-rescan-r - Reuse same scanner several times, reentrant.
-string-nr - Scan strings, non-reentrant.
-string-r - Scan strings, reentrant.
-table-opts - Try every table compression option.
-top - Test %top directive.
-yyextra - Test yyextra.
-alloc-extra - Test yy_init_extra and providing your own yyalloc.
-c++-yywrap - test yywrap in c++ scanner
-concatenated-options - test parsing of multiple concatenated short options