summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2016-02-27 15:35:33 -0500
committerWill Estes <westes575@gmail.com>2016-02-27 15:35:33 -0500
commit0e2b8c0f95f3c09be0470c9b2d002a8e194ae9b5 (patch)
tree713d986aaabae1015a6c0b44caa05e051e9c96cb
parent09fd5851bcf69a0d8913b58fd9dae85ef8c006bc (diff)
Made some program checks more robust
-rw-r--r--configure.ac20
1 files changed, 9 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 72b90af..8d4bcc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,21 +51,19 @@ AC_PROG_RANLIB
AC_PATH_PROG([BISON], bison, no)
AS_IF([test "$BISON" != no],[],
- [ AC_SUBST([BISON], [\${top_srcdir}/build-aux/missing bison])
+ [ AC_SUBST([BISON], [\${top_srcdir}/build-aux/missing bison])
AC_MSG_NOTICE(no bison program found: only required for maintainers)
])
-AC_PATH_PROG([HELP2MAN], help2man, no)
-AS_IF([test "$HELP2MAN" != no],[],i
- [ AC_SUBST([HELP2MAN], [\${top_srcdir}/build-aux/missing help2man])
- AC_MSG_NOTICE(no help2man program found: only required for maintainers)
- ])
+AC_PATH_PROG([HELP2MAN], help2man, [\${top_srcdir}/build-aux/missing help2man])
+ AS_IF([test -z "$ac_cv_path_HELP2MAN" ],[],
+ AC_MSG_WARN(program not found: help2man: building man page will not work)
+ )
-AC_PATH_PROGS([TEXI2DVI], [gtexi2dvi texi2dvi], [no])
-AS_IF([test "$TEXI2DVI" != no],[],
- [ AC_SUBST([TEXI2DVI], [:])
- AC_MSG_NOTICE(no texi2dvi program found: only required for maintainers)
- ])
+AC_PATH_PROGS([TEXI2DVI], [gtexi2dvi texi2dvi], [\${top_srcdir}/build-aux/missing texi2dvi])
+ AS_IF([test -z "$ac_cv_path_TEXI2DVI" ], [],
+ AC_MSG_WARN(texi2dvi: program not found: building pdf version of manual will not work)
+ )
# Check for a m4 that supports -P