summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Millaway <john43@users.sourceforge.net>2006-02-14 20:23:47 +0000
committerJohn Millaway <john43@users.sourceforge.net>2006-02-14 20:23:47 +0000
commit3b1d83312afd796a1691f6cda10c34993cef019f (patch)
tree30516796568d6ad07a85cc54ce69780f87947dd8
parentc42c40874a6f7f01904ac4ac7d6c70d1ab64aa77 (diff)
Added C99 macro for inttypes, just to be conformant.
-rw-r--r--configure.in1
-rw-r--r--flexint.h8
2 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0b021f0..b569776 100644
--- a/configure.in
+++ b/configure.in
@@ -83,6 +83,7 @@ AC_CHECK_HEADERS(unistd.h stdbool.h netinet/in.h limits.h)
AC_CHECK_HEADERS( sys/wait.h sys/params.h)
AC_CHECK_HEADERS(cunistd)
AC_CHECK_HEADERS(locale.h libintl.h)
+AC_CHECK_HEADERS(regex.h)
dnl checks for types
diff --git a/flexint.h b/flexint.h
index be824de..4088715 100644
--- a/flexint.h
+++ b/flexint.h
@@ -6,6 +6,14 @@
/* C99 systems have <inttypes.h>. Non-C99 systems may or may not. */
#if __STDC_VERSION__ >= 199901L
+
+/* C99 says to define __STDC_LIMIT_MACROS before including stdint.h,
+ * if you want the limit (max/min) macros for int types.
+ */
+#ifndef __STDC_LIMIT_MACROS
+#define __STDC_LIMIT_MACROS 1
+#endif
+
#include <inttypes.h>
typedef int8_t flex_int8_t;
typedef uint8_t flex_uint8_t;