summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2016-11-19 02:37:04 +0800
committerWill Estes <westes575@gmail.com>2016-11-24 18:45:07 -0500
commit713f5a0cb4ba5e4bfebae125edf4111fd8dae803 (patch)
tree3f648b9c502e61a3f02b8482abc592d18eda5124
parent11c445cde95ec4ba146b180bf3a2501cc6e255da (diff)
build: Link $(LIBOBJS) from src/ dir, remove libcompat.la.
The libcompat.la library was small and less friendly to bootstrapping and cross compilation. Now, we will simply link individual object files as needed, which is simpler.
-rw-r--r--configure.ac2
-rw-r--r--lib/Makefile.am5
-rw-r--r--lib/lib.c9
-rw-r--r--src/Makefile.am2
4 files changed, 3 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 362740a..bb8287f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,7 +28,7 @@ AC_INIT([the fast lexical analyser generator],[2.6.3],[flex-help@lists.sourcefor
AC_CONFIG_SRCDIR([src/scan.l])
AC_CONFIG_AUX_DIR([build-aux])
LT_INIT
-AM_INIT_AUTOMAKE([-Wno-portability foreign check-news std-options dist-lzip parallel-tests 1.14.1])
+AM_INIT_AUTOMAKE([-Wno-portability foreign check-news std-options dist-lzip parallel-tests subdir-objects 1.14.1])
AC_CONFIG_HEADER([src/config.h])
AC_CONFIG_LIBOBJ_DIR([lib])
AC_CONFIG_MACRO_DIR([m4])
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 011163e..9ce06a8 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,4 +1 @@
-noinst_LTLIBRARIES = libcompat.la
-libcompat_la_SOURCES = lib.c
-libcompat_la_LIBADD = $(LTLIBOBJS)
-
+# dummy
diff --git a/lib/lib.c b/lib/lib.c
deleted file mode 100644
index 4b4bf73..0000000
--- a/lib/lib.c
+++ /dev/null
@@ -1,9 +0,0 @@
-/* Since building an empty library could cause problems, we provide a
- * function to go into the library. We could make this non-trivial by
- * moving something that flex treats as a library function into this
- * directory. */
-
-extern void do_nothing(void);
-
-void do_nothing(void){ return;}
-
diff --git a/src/Makefile.am b/src/Makefile.am
index b5b34d4..fdd3c92 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -59,7 +59,7 @@ COMMON_SOURCES = \
version.h \
yylex.c
-LDADD = ../lib/libcompat.la @LIBINTL@
+LDADD = $(LIBOBJS) @LIBINTL@
include_HEADERS = \
FlexLexer.h