summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2003-02-27 15:37:44 +0000
committerWill Estes <wlestes@users.sourceforge.net>2003-02-27 15:37:44 +0000
commitc863276feb9ebec651b8840ffcd278e5ce9ce8e9 (patch)
treebf6f0b7922a5dbc7ea0bfe9c224f6bedb38e3242
parent833f8a5da0c86aea228c5bb701a192154904a1e9 (diff)
move flex.texi and flex.1 to new doc/ subdirectory
-rw-r--r--Makefile.am19
-rw-r--r--NEWS2
-rw-r--r--configure.in1
-rw-r--r--doc/.cvsignore26
-rw-r--r--doc/Makefile.am22
-rw-r--r--doc/flex.texi (renamed from flex.texi)0
6 files changed, 53 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index bc20331..aaefa24 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,7 +35,6 @@
AM_YFLAGS = -d
ACLOCAL_AMFLAGS = -I m4
-help2man = @HELP2MAN@
m4 = @M4@
indent = @INDENT@
@@ -45,7 +44,6 @@ AUTOMAKE_OPTIONS = \
dist-bzip2 \
1.7
-
bin_PROGRAMS = flex
lib_LIBRARIES = libfl.a
@@ -85,11 +83,7 @@ noinst_HEADERS = \
include_HEADERS = \
FlexLexer.h
-info_TEXINFOS = flex.texi
-man_MANS = flex.1
-
MAINTAINERCLEANFILES = \
- flex.1 \
ABOUT-NLS \
config.rpath \
config.sub \
@@ -98,8 +92,6 @@ MAINTAINERCLEANFILES = \
config.sub \
config.guess \
depcomp \
- flex.hks \
- flex.ops \
mkinstalldirs \
install-sh \
ABOUT-NLS \
@@ -132,13 +124,13 @@ EXTRA_DIST = \
mkskel.sh \
ABOUT-NLS \
config.rpath \
- gettext.h \
- $(man_MANS)
+ gettext.h
BUILT_SOURCES = \
skel.c
SUBDIRS = \
+ doc \
m4 \
examples \
po \
@@ -151,13 +143,6 @@ LIBS = @LIBINTL@ @LIBS@
skel.c: flex.skl mkskel.sh flexint.h tables_shared.h
$(m4) -P -DFLEX_MAJOR_VERSION=`echo $(VERSION)|cut -f 1 -d .` -DFLEX_MINOR_VERSION=`echo $(VERSION)|cut -f 2 -d .` -DFLEX_SUBMINOR_VERSION=`echo $(VERSION)|cut -f 3 -d .` $(srcdir)/flex.skl | $(SHELL) $(srcdir)/mkskel.sh >skel.c
-if MAINTAINER_MODE
-$(man_MANS): $(srcdir)/main.c
- for i in $(man_MANS) ; do \
- $(help2man) --name='fast lexical analyzer generator' --section=`echo $$i|rev|cut -f 1 -d .|rev` @builddir@/flex > $$i ; \
- done
-endif
-
# Explicitly describe dependencies.
# You can recreate this with `gcc -I. -MM *.c'
buf.o: buf.c flexdef.h flexint.h
diff --git a/NEWS b/NEWS
index 5106788..a918fef 100644
--- a/NEWS
+++ b/NEWS
@@ -5,6 +5,8 @@ See the file COPYING for copying conditions.
* after version 2.5.28
+** moved the flex documentation to a new doc/ subdirectory
+
** cleanups to the yy namespace
* version 2.5.28 released 2003-2-12
diff --git a/configure.in b/configure.in
index c39bbda..0c18d00 100644
--- a/configure.in
+++ b/configure.in
@@ -78,6 +78,7 @@ AC_CHECK_DECLS(__func__)
AC_CONFIG_FILES(
flex.spec
Makefile
+doc/Makefile
examples/Makefile
examples/fastwc/Makefile
examples/manual/Makefile
diff --git a/doc/.cvsignore b/doc/.cvsignore
new file mode 100644
index 0000000..44079ad
--- /dev/null
+++ b/doc/.cvsignore
@@ -0,0 +1,26 @@
+*.aux
+*.cp
+*.cps
+*.dvi
+*.fn
+*.fns
+*.hk
+*.hks
+*.info*
+*.ky
+*.log
+*.op
+*.ops
+*.pg
+*.toc
+*.tp
+*.tps
+*.vr
+*.vrs
+Makefile
+Makefile.in
+flex.1
+mdate-sh
+stamp-*
+texinfo.tex
+version.texi
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..a15ec54
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,22 @@
+help2man = @HELP2MAN@
+
+info_TEXINFOS = flex.texi
+man_MANS = flex.1
+
+MAINTAINERCLEANFILES = \
+ flex.1 \
+ flex.hks \
+ flex.ops
+
+EXTRA_DIST = \
+ $(man_MANS)
+
+if MAINTAINER_MODE
+../flex:
+ cd .. && $(MAKE) flex
+
+$(man_MANS): $(top_srcdir)/main.c ../flex
+ for i in $(man_MANS) ; do \
+ $(help2man) --name='fast lexical analyzer generator' --section=`echo $$i|rev|cut -f 1 -d .|rev` ../flex > $$i ; \
+ done
+endif
diff --git a/flex.texi b/doc/flex.texi
index 9a0d057..9a0d057 100644
--- a/flex.texi
+++ b/doc/flex.texi