summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2018-02-13 15:26:36 -0800
committerManoj Srivastava <srivasta@debian.org>2018-02-13 15:26:36 -0800
commit62ca792ea0fecb4f7d6848679cb8cc0565772a4d (patch)
treeb0dd536ff80ac33c9991bbc3b2c84f7c1f95e1e2
parent9e8dc74e7b8bb1f35fed819043da5c7841bfae97 (diff)
[master]: New bug fixing releasedebian/2.6.4-2archive/debian/2.6.4-2
Fixes the cross compilation issue that resurfaced. Closes: Bug#833146 Signed-off-by: Manoj Srivastava <srivasta@debian.org>
-rw-r--r--debian/changelog13
-rwxr-xr-xdebian/rules18
-rw-r--r--debian/watch6
3 files changed, 34 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index fd932c4..95ec609 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+flex (2.6.4-2) unstable; urgency=medium
+
+ * Added get-orig-source target, and updated the watch file
+ * Bug fix: "flex FTCBFS: executes host architectue stage1flex during
+ build", thanks to Helmut Grohne (Closes: #833146). This reinstates
+ Helmut's original fix. There was a question about not using help2man
+ in the first place. I considered it; but upstream continues to use
+ help2man, including it in autoconf. I think Helmut's fix is elegant,
+ and saves work as flex's options change over time, and is a smaller
+ delta from upstream.
+
+ -- Manoj Srivastava <srivasta@debian.org> Tue, 13 Feb 2018 15:25:11 -0800
+
flex (2.6.4-1) unstable; urgency=medium
* New upstream version. Notable changes
diff --git a/debian/rules b/debian/rules
index 029e492..7b03f9b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,6 +17,16 @@ DPKG_ARCH := dpkg-architecture
export DEB_HOST_MULTIARCH := $(shell $(DPKG_ARCH) $(ha) -qDEB_HOST_MULTIARCH)
export DEB_BUILD_MULTIARCH := $(shell $(DPKG_ARCH) $(ha) -qDEB_BUILD_MULTIARCH)
+# Common useful variables
+DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' $(SRCTOP)/debian/control | \
+ cut -f 2 -d ':'))
+DEB_VERSION := $(strip $(shell LC_ALL=C dpkg-parsechangelog | \
+ egrep '^Version:' | cut -f 2 -d ' '))
+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
+DEB_REVISION := $(strip $(shell echo $(DEB_NOEPOCH_VERSION) | \
+ perl -ple 's/.+\-(.+)$$/$$1/msxg'))
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
+
confflags = ac_cv_lib_util_getloadavg=no
ifneq ($(DEB_BUILD_MULTIARCH),$(DEB_HOST_MULTIARCH))
confflags += ac_cv_func_malloc_0_nonnull=yes ac_cv_func_realloc_0_nonnull=yes
@@ -73,6 +83,14 @@ endif
bash -n debian/flex.postinst
bash -n debian/flex.prerm
+.PHONY: get-orig-source
+## http://wiki.debian.org/onlyjob/get-orig-source
+get-orig-source: $(info I: $(package)_$(DEB_UPSTREAM_VERSION))
+ @echo "Downloading $(package) $(DEB_UPSTREAM_VERSION)"
+ uscan --noconf --verbose --rename --destdir=$(CURDIR) \
+ --check-dirname-level=0 --force-download \
+ --download-version $(DEB_UPSTREAM_VERSION) $(SRCTOP)
+
#Local variables:
#mode: makefile
#End:
diff --git a/debian/watch b/debian/watch
index 3b66e2b..d0905a4 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,6 +1,6 @@
# format version number, currently 2; this line is compulsory!
version=4
-opt="pgpmode=next" https://github.com/westes/@PACKAGE@/releases \
+
+opts=pgpsigurlmangle=s/(\d\S+)\.tar\.gz/$1\.tar\.gz\.sig/ \
+https://github.com/westes/@PACKAGE@/releases \
/westes/@PACKAGE@/releases/download/v[\d\.]*/@PACKAGE@@ANY_VERSION@@ARCHIVE_EXT@ debian
-opt="pgpmode=previous" https://github.com/westes/@PACKAGE@/releases \
- /westes/@PACKAGE@/releases/download/v[\d\.]*/@PACKAGE@@ANY_VERSION@@ARCHIVE_EXT@@SIGNATURE_EXT@ previous uupdate