summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2002-12-02 20:48:44 +0000
committerWill Estes <wlestes@users.sourceforge.net>2002-12-02 20:48:44 +0000
commit7ec78e5eb7c31bf1f5021e7ea99705fe28502058 (patch)
treebbfe449faaa0cdf40308aeacf60ca01638220c9e /Makefile.am
parent2ba7cd078c16e73ca434eed47cbab5b47950bd7b (diff)
enclose flex.1 target in MAINTERNER_MODE
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d93a435..fb6999f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -149,10 +149,12 @@ LIBS = @LIBINTL@ @LIBS@
skel.c: flex.skl mkskel.sh flexint.h tables_shared.h
$(m4) -P -DFLEX_MAJOR_VERSION=`echo $(VERSION)|cut -f 1 -d .` -DFLEX_MINOR_VERSION=`echo $(VERSION)|cut -f 2 -d .` -DFLEX_SUBMINOR_VERSION=`echo $(VERSION)|cut -f 3 -d .` $(srcdir)/flex.skl | $(SHELL) $(srcdir)/mkskel.sh >skel.c
+if MAINTAINER_MODE
$(man_MANS): $(srcdir)/main.c
for i in $(man_MANS) ; do \
$(help2man) --name='fast lexical analyzer generator' --section=`echo $$i|rev|cut -f 1 -d .|rev` @builddir@/flex > $$i ; \
done
+endif
# Explicitly describe dependencies.
# You can recreate this with `gcc -I. -MM *.c'