summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Millaway <john43@users.sourceforge.net>2002-03-28 19:52:33 +0000
committerJohn Millaway <john43@users.sourceforge.net>2002-03-28 19:52:33 +0000
commit712c03b38fb35f9d7f16e0fdd27441c3efda0071 (patch)
tree08ff0511d9f7e87cd0b0062239cbcd4f2e44c963 /Makefile.am
parentf9365ab47fde213a761f90a5a0cc6437a4f30968 (diff)
Output of `flex --version` now matches GNU coding standards.
Makefile.am now uses `help2man` to generate flex.1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8975079..febfdf7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,6 +79,7 @@ include_HEADERS = \
FlexLexer.h
info_TEXINFOS = flex.texi
+man1_MANS = flex.1
EXTRA_DIST = \
AUTHORS \
@@ -95,7 +96,8 @@ EXTRA_DIST = \
mkskel.sh \
ABOUT-NLS \
config.rpath \
- gettext.h
+ gettext.h \
+ flex.1
BUILT_SOURCES = \
skel.c \
@@ -120,6 +122,9 @@ yylex.o: yylex.c parse.h flexdef.h config.h
skel.c: flex.skl mkskel.sh
$(SHELL) $(srcdir)/mkskel.sh $(srcdir)/flex.skl >skel.c
+flex.1: flex
+ help2man --name='fast lexical analyzer generator' --section=1 ./flex >flex.1
+
main.o: main.c flexdef.h config.h version.h
ccl.o: ccl.c flexdef.h config.h
dfa.o: dfa.c flexdef.h config.h