summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Millaway <john43@users.sourceforge.net>2002-02-24 22:19:57 +0000
committerJohn Millaway <john43@users.sourceforge.net>2002-02-24 22:19:57 +0000
commit655d07a2278d1caa12e6c3161f89ea48e8204f12 (patch)
treed0b806ac60ec1c532c4ccecea9669475b631ed3a /Makefile.am
parentc21c0d52f7233d04b9c58a62d300c60c8e1e7032 (diff)
Removed CVS-specific code from 'dist-hook' target so anybody with a copy of the
tree can build a dist.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 83484cc..185a747 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -91,7 +91,11 @@ EXTRA_DIST = \
TODO \
autogen.sh \
flex.skl \
- mkskel.sh
+ mkskel.sh \
+ tests \
+ to.do \
+ examples \
+ faqs
BUILT_SOURCES = \
skel.c
@@ -128,8 +132,7 @@ ChangeLog:
.PHONY: ChangeLog
dist-hook:
- -for i in tests to.do examples faqs ; \
- do \
- cvs -d /usr/local/cvsroot -Q export -D today -d $(PACKAGE)-$(VERSION)/$$i $(PACKAGE)/$$i ; \
- done
+ -if test ! "x$(distdir)" = "x" ; then \
+ rm -rf `find $(distdir)/ -name CVS` ;\
+ fi;
-cd $(PACKAGE)-$(VERSION) && ./autogen.sh