summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2003-02-27 15:37:44 +0000
committerWill Estes <wlestes@users.sourceforge.net>2003-02-27 15:37:44 +0000
commitc863276feb9ebec651b8840ffcd278e5ce9ce8e9 (patch)
treebf6f0b7922a5dbc7ea0bfe9c224f6bedb38e3242 /Makefile.am
parent833f8a5da0c86aea228c5bb701a192154904a1e9 (diff)
move flex.texi and flex.1 to new doc/ subdirectory
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 2 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index bc20331..aaefa24 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,7 +35,6 @@
AM_YFLAGS = -d
ACLOCAL_AMFLAGS = -I m4
-help2man = @HELP2MAN@
m4 = @M4@
indent = @INDENT@
@@ -45,7 +44,6 @@ AUTOMAKE_OPTIONS = \
dist-bzip2 \
1.7
-
bin_PROGRAMS = flex
lib_LIBRARIES = libfl.a
@@ -85,11 +83,7 @@ noinst_HEADERS = \
include_HEADERS = \
FlexLexer.h
-info_TEXINFOS = flex.texi
-man_MANS = flex.1
-
MAINTAINERCLEANFILES = \
- flex.1 \
ABOUT-NLS \
config.rpath \
config.sub \
@@ -98,8 +92,6 @@ MAINTAINERCLEANFILES = \
config.sub \
config.guess \
depcomp \
- flex.hks \
- flex.ops \
mkinstalldirs \
install-sh \
ABOUT-NLS \
@@ -132,13 +124,13 @@ EXTRA_DIST = \
mkskel.sh \
ABOUT-NLS \
config.rpath \
- gettext.h \
- $(man_MANS)
+ gettext.h
BUILT_SOURCES = \
skel.c
SUBDIRS = \
+ doc \
m4 \
examples \
po \
@@ -151,13 +143,6 @@ LIBS = @LIBINTL@ @LIBS@
skel.c: flex.skl mkskel.sh flexint.h tables_shared.h
$(m4) -P -DFLEX_MAJOR_VERSION=`echo $(VERSION)|cut -f 1 -d .` -DFLEX_MINOR_VERSION=`echo $(VERSION)|cut -f 2 -d .` -DFLEX_SUBMINOR_VERSION=`echo $(VERSION)|cut -f 3 -d .` $(srcdir)/flex.skl | $(SHELL) $(srcdir)/mkskel.sh >skel.c
-if MAINTAINER_MODE
-$(man_MANS): $(srcdir)/main.c
- for i in $(man_MANS) ; do \
- $(help2man) --name='fast lexical analyzer generator' --section=`echo $$i|rev|cut -f 1 -d .|rev` @builddir@/flex > $$i ; \
- done
-endif
-
# Explicitly describe dependencies.
# You can recreate this with `gcc -I. -MM *.c'
buf.o: buf.c flexdef.h flexint.h