summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2002-10-22 13:37:05 +0000
committerWill Estes <wlestes@users.sourceforge.net>2002-10-22 13:37:05 +0000
commitceacaabc0e18efb680e34d97c7c9c5d15de4cbca (patch)
treee9763484638818ed772a62ca33fb1d3059f1071a /Makefile.am
parentd7c76591fd1ea9f802ffbe7d9ae9e619bd23fff1 (diff)
include intent.pro; indent target is MAINTAINER_MODE conditional
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 968b14c..89d2384 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -89,6 +89,7 @@ info_TEXINFOS = flex.texi
man_MANS = flex.1
EXTRA_DIST = \
+ .indent.pro \
AUTHORS \
COPYING \
INSTALL \
@@ -162,6 +163,7 @@ tags:
ChangeLog:
-rcs2log -l 72 -u "vern Vern vern@ee.lbl.gov" -u "wlestes W. L. Estes wlestes@uncg.edu" -u "millaway John Millaway millaway@acm.org" | sed s:/usr/local/cvsroot/flex/::g >ChangeLog
+if MAINTAINER_MODE
# Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
#
# Whole idea:
@@ -184,5 +186,6 @@ indent:
$(indent) < $$f >/dev/null && indent $$f || echo $$f FAILED to indent ;\
done \
fi
+endif MAINTAINER_MODE
.PHONY: ChangeLog tags indent