summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2003-03-26 19:15:31 +0000
committerWill Estes <wlestes@users.sourceforge.net>2003-03-26 19:15:31 +0000
commit9709dfdf79655c48d782e99417d97daf54319215 (patch)
treee4728f79122f56c4d023d042060218b16369e342 /Makefile.am
parentac7953a808cf9bdb9603d9998076a74788bcbf7f (diff)
only rebuild the ChangeLog if we're inside a cvs working directory
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ed120d3..1dc346b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -177,10 +177,12 @@ filter.o: filter.c flexdef.h flexint.h
tags:
ctags --c-types='defgmstuv' $(srcdir)/*.[ch]
-# Create the ChangeLog
+# Create the ChangeLog, but only if we're inside a cvs working directory
ChangeLog:
- sh $(srcdir)/tools/cvs2cl.pl -F trunk -U $(srcdir)/tools/cvsauthors
+ if [ -d CVS ] ; then \
+ sh $(srcdir)/tools/cvs2cl.pl -F trunk -U $(srcdir)/tools/cvsauthors \
+ ; fi
# Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
#