summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-12-06 09:29:42 -0700
committerWill Estes <westes575@gmail.com>2012-12-08 13:59:18 -0500
commitdc56dc5103704660208d2b15d771ba94df166b71 (patch)
treecf0091009935e9fc4c80ed04a3ee4501ee0e2ed3 /Makefile.am
parentb0ccdd451b88a1ba8f83508223e8c50bd52e859d (diff)
add version information to shared library
Signed-off-by: Will Estes <westes575@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d561f72..d052b94 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,10 +73,14 @@ libfl_la_SOURCES = \
libmain.c \
libyywrap.c
+libfl_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
+
libfl_pic_la_SOURCES = \
libmain.c \
libyywrap.c
+libfl_pic_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
+
noinst_HEADERS = \
flexdef.h \
flexint.h \