summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2002-10-08 15:15:57 +0000
committerWill Estes <wlestes@users.sourceforge.net>2002-10-08 15:15:57 +0000
commit7fa5bf03416d0a42471673a4853386853483706b (patch)
treefe44b4c8bf1000c5ed7c62ed17aaa76b8321fc56 /Makefile.am
parent798e5a60fc028f87b4e67cc49ce15fad6c8e0a83 (diff)
remove README-alpha option; add definitions for FLEX_{MAJOR,MINOR,SUBMINOR}_VERSION
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 475ee32..d849e03 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,7 +40,6 @@ m4 = @M4@
indent = @INDENT@
AUTOMAKE_OPTIONS = \
- readme-alpha \
gnits \
check-news \
dist-bzip2 \
@@ -127,7 +126,7 @@ AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
LIBS = @LIBINTL@ @LIBS@
skel.c: flex.skl mkskel.sh
- $(m4) -P -DVERSION=$(VERSION) $(srcdir)/flex.skl | $(SHELL) $(srcdir)/mkskel.sh >skel.c
+ $(m4) -P -DFLEX_MAJOR_VERSION=`echo $(VERSION)|cut -f 1 -d .` -DFLEX_MINOR_VERSION=`echo $(VERSION)|cut -f 2 -d .` -DFLEX_SUBMINOR_VERSION=`echo $(VERSION)|cut -f 3 -d .` $(srcdir)/flex.skl | $(SHELL) $(srcdir)/mkskel.sh >skel.c
$(man_MANS): $(srcdir)/main.c
for i in $(man_MANS) ; do \