summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2012-08-02 13:05:40 -0400
committerWill Estes <westes575@gmail.com>2012-08-02 13:05:40 -0400
commit9a66aa30e20059853f78a0ce60638eb81eb2dfe7 (patch)
treec5e2055310034c62cc3bcba912a9b5d1d5bcd338 /Makefile.am
parent60562d47d6e1e70528633951ccca1eed49ef4549 (diff)
Add -f option to LN_S to create flex++
The autoconf macro LN_S needs -f to successfully install flex++ if flex++ already exists. Fortunately, ln, ln -s and cp -p, which are the various forms that LN_S can take all will do the right thing with a -f argument passed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 961d740..63e5e65 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -211,6 +211,6 @@ indent:
install-exec-hook:
cd $(DESTDIR)/$(bindir) && \
- $(LN_S) flex$(EXEEXT) flex++$(EXEEXT)
+ $(LN_S) -f flex$(EXEEXT) flex++$(EXEEXT)
.PHONY: ChangeLog tags indent