summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2017-01-02 00:38:37 +0800
committerWill Estes <westes575@gmail.com>2017-01-12 18:02:24 -0500
commitbb92951c022ea135d2f9dbc51dd9803ac7cd97ad (patch)
tree2256ee55521f3fae5e7d29961070536d8283f863 /Makefile.am
parent8db5267af4dfe10b0059c16d2b728bfb43146f63 (diff)
build: Fix 'make indent' target
This 'make indent' target has not been working since the directories reorganization in flex 2.6.0. Now make it work again. Note that the current indent profile breaks many styles of existing code. The indent target should not be used until the .indent.pro options are reviewed for desireability.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1540bb7..807a109 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,7 +29,6 @@
# to DEFS.
ACLOCAL_AMFLAGS = -I m4
-indent = @INDENT@
dist_doc_DATA = \
AUTHORS \
@@ -58,8 +57,11 @@ ChangeLog: $(srcdir)/tools/git2cl
$(srcdir)/tools/git2cl > $@ \
; fi
+indent:
+ cd src && $(MAKE) $(AM_MAKEFLAGS) indent
+
install-exec-hook:
cd $(DESTDIR)$(bindir) && \
$(LN_S) -f flex$(EXEEXT) flex++$(EXEEXT)
-.PHONY: ChangeLog tags indent
+.PHONY: ChangeLog indent