summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlastair Hughes <hobbitalastair@gmail.com>2016-10-28 11:19:31 +1300
committerWill Estes <westes575@gmail.com>2016-10-29 09:11:20 -0400
commit75f4305eedca268156b5c72204aa768a73fcaa3e (patch)
tree824abf0ffd95999fecebdda04f3a66eabfb8b58f /configure.ac
parentc503eaf061145b97dd04af3fd01138e041425317 (diff)
build: fix false negatives for help2man and texi2dvi
HELP2MAN and TEXI2DVI (or the corresponding ac_prog variables) will never be zero length as they fall back to the missing script; check for the fall back and warn on that instead of always warning.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 666b69f..674c0a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,12 +67,12 @@ AS_IF([test "$BISON" != no],[],
])
AC_PATH_PROG([HELP2MAN], help2man, [\${top_srcdir}/build-aux/missing help2man])
- AS_IF([test -z "$ac_cv_path_HELP2MAN" ],[],
- AC_MSG_WARN(program not found: help2man: building man page will not work)
+ AS_IF([test "$HELP2MAN" = "\${top_srcdir}/build-aux/missing help2man"],
+ AC_MSG_WARN(help2man: program not found: building man page will not work)
)
AC_PATH_PROGS([TEXI2DVI], [gtexi2dvi texi2dvi], [\${top_srcdir}/build-aux/missing texi2dvi])
- AS_IF([test -z "$ac_cv_path_TEXI2DVI" ], [],
+ AS_IF([test "$TEXI2DVI" = "\${top_srcdir}/build-aux/missing texi2dvi"],
AC_MSG_WARN(texi2dvi: program not found: building pdf version of manual will not work)
)