summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-07-31 15:00:12 -0700
committerManoj Srivastava <srivasta@debian.org>2016-07-31 15:00:12 -0700
commitdc20a68ba953b2a5da0311f3ce9f9217f9ad60b3 (patch)
treee45fdd69828a8668029d07f8601442cbb9258559 /configure.ac
parente68e1da425634fda40095a7b3196d4175f782987 (diff)
parent487177cbb85bc4e88e468c71b27569054b8df090 (diff)
Merge branch 'upstream'
Signed-off-by: Manoj Srivastava <srivasta@debian.org> # Conflicts: # src/buf.c # src/flex.skl # src/skel.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 29 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 426877a..d80a9d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,12 +24,11 @@
# autoconf requirements and initialization
-AC_INIT([the fast lexical analyser generator], [2.6.0],
-[flex-help@lists.sourceforge.net], [flex])
+AC_INIT([the fast lexical analyser generator],[2.6.1],[flex-help@lists.sourceforge.net],[flex])
AC_CONFIG_SRCDIR([src/scan.l])
AC_CONFIG_AUX_DIR([build-aux])
LT_INIT
-AM_INIT_AUTOMAKE([gnu check-news std-options dist-bzip2 dist-xz parallel-tests 1.14.1])
+AM_INIT_AUTOMAKE([gnu check-news std-options dist-xz parallel-tests 1.14.1])
AC_CONFIG_HEADER([src/config.h])
AC_CONFIG_LIBOBJ_DIR([lib])
AC_CONFIG_MACRO_DIR([m4])
@@ -49,8 +48,21 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_INSTALL
-AC_PATH_PROG(BISON, bison,bison)
-AC_PATH_PROG(HELP2MAN, help2man, help2man)
+AC_PATH_PROG([BISON], bison, no)
+AS_IF([test "$BISON" != no],[],
+ [ AC_SUBST([BISON], [\${top_srcdir}/build-aux/missing bison])
+ AC_MSG_NOTICE(no bison program found: only required for maintainers)
+ ])
+
+AC_PATH_PROG([HELP2MAN], help2man, [\${top_srcdir}/build-aux/missing help2man])
+ AS_IF([test -z "$ac_cv_path_HELP2MAN" ],[],
+ AC_MSG_WARN(program not found: help2man: building man page will not work)
+ )
+
+AC_PATH_PROGS([TEXI2DVI], [gtexi2dvi texi2dvi], [\${top_srcdir}/build-aux/missing texi2dvi])
+ AS_IF([test -z "$ac_cv_path_TEXI2DVI" ], [],
+ AC_MSG_WARN(texi2dvi: program not found: building pdf version of manual will not work)
+ )
if test "$cross_compiling" = yes; then
FLEXexe='flex$(EXEEXT)'
@@ -86,9 +98,7 @@ fi
# checks for headers
-AC_HEADER_STDC
-AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS([inttypes.h libintl.h limits.h locale.h malloc.h netinet/in.h regex.h stddef.h stdlib.h string.h strings.h unistd.h])
+AC_CHECK_HEADERS([inttypes.h libintl.h limits.h locale.h malloc.h netinet/in.h regex.h unistd.h])
# checks for libraries
@@ -117,7 +127,17 @@ AC_FUNC_ALLOCA
AC_FUNC_FORK
AC_FUNC_MALLOC
AC_FUNC_REALLOC
-AC_CHECK_FUNCS([dup2 isascii memset pow regcomp setlocale strchr strtol])
+
+AC_CHECK_FUNCS(dup2 dnl
+memset dnl
+pow dnl
+regcomp dnl
+setlocale dnl
+strchr dnl
+strdup dnl
+strtol)
+
+AC_REPLACE_FUNCS(reallocarray)
# are we ignoring tests
AM_CONDITIONAL([SKIP_TEST], [ "$(echo $DEB_BUILD_OPTIONS | grep nocheck)" ])