summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2018-02-08 17:47:37 -0800
committerManoj Srivastava <srivasta@debian.org>2018-02-08 17:47:37 -0800
commit04687c439c4e99abd0bc29506ceaa293a6330d9c (patch)
tree6499a0ecf7c445b8634fe436a0b04af4296bdce5 /configure.ac
parent7a39ce3d46f3d049ead08a455c5fcb1b37e153e3 (diff)
parentff7bc8af4680a6b16b07f8ddae8b5c64ad009de1 (diff)
Update to a new upstream commit for some bug fixes.
Signed-off-by: Manoj Srivastava <srivasta@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 55e774b..3c977a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,10 +25,12 @@
# autoconf requirements and initialization
AC_INIT([the fast lexical analyser generator],[2.6.4],[flex-help@lists.sourceforge.net],[flex])
+AC_PREREQ([2.60])
AC_CONFIG_SRCDIR([src/scan.l])
AC_CONFIG_AUX_DIR([build-aux])
+AC_USE_SYSTEM_EXTENSIONS
LT_INIT
-AM_INIT_AUTOMAKE([1.11.3 -Wno-portability foreign check-news std-options dist-lzip parallel-tests subdir-objects])
+AM_INIT_AUTOMAKE([1.15 -Wno-portability foreign std-options dist-lzip parallel-tests subdir-objects])
AC_CONFIG_HEADER([src/config.h])
AC_CONFIG_LIBOBJ_DIR([lib])
AC_CONFIG_MACRO_DIR([m4])
@@ -38,7 +40,7 @@ AC_SUBST(SHARED_VERSION_INFO)
# checks for programs
AM_GNU_GETTEXT([external])
-AM_GNU_GETTEXT_VERSION([0.18])
+AM_GNU_GETTEXT_VERSION([0.19.7])
AC_PROG_YACC
AS_IF([test "$YACC" != 'bison -y'], [
YACC="\${top_srcdir}/build-aux/missing bison -y"
@@ -54,6 +56,9 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_INSTALL
+pkgconfigdir=${libdir}/pkgconfig
+AC_SUBST(pkgconfigdir)
+
# allow passing a variable `WARNINGFLAGS',
# either when invoking `configure', or when invoking `make'
# default to something useful if GCC was detected
@@ -166,6 +171,7 @@ strtol dnl
AC_CHECK_FUNCS([dnl
pow dnl Used only by "examples/manual/expr"
setlocale dnl Needed only if NLS is enabled
+reallocarr dnl NetBSD function. Use reallocarray if not available.
reallocarray dnl OpenBSD function. We have replacement if not available.
])
@@ -176,6 +182,7 @@ examples/Makefile
examples/fastwc/Makefile
examples/manual/Makefile
po/Makefile.in
+src/libfl.pc
src/Makefile
tools/Makefile
tests/Makefile