summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2016-11-20 10:19:36 +0800
committerWill Estes <westes575@gmail.com>2016-11-24 18:48:28 -0500
commit44fa75893187b710d5e8042524232d96d3e0ea48 (patch)
treeb9f1039db0342c24f2bac48706fcd5e3dc36d696 /configure.ac
parent713f5a0cb4ba5e4bfebae125edf4111fd8dae803 (diff)
build: warn about cross compiling with *alloc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bb8287f..5a29b79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,8 +136,14 @@ AC_TYPE_SIZE_T
AC_FUNC_ALLOCA
AC_FUNC_FORK
+dnl Autoconf bug: AC_FUNC_MALLOC and AC_FUNC_REALLOC might not warn of cross
+dnl compilation. Workaround this.
AC_FUNC_MALLOC
+AS_IF([test "$cross_compiling" = yes],
+ AC_MSG_WARN([result $ac_cv_func_malloc_0_nonnull guessed because of cross compilation]))
AC_FUNC_REALLOC
+AS_IF([test "$cross_compiling" = yes],
+ AC_MSG_WARN([result $ac_cv_func_realloc_0_nonnull guessed because of cross compilation]))
AC_CHECK_FUNCS(dup2 dnl
memset dnl