summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-02-16 21:56:26 -0800
committerManoj Srivastava <srivasta@debian.org>2016-02-16 21:56:26 -0800
commit45b7ac5a5a43bd4c4d7ce0ecefc5fdbcd4d1b473 (patch)
tree52cfcbda0eeefcb1b85065e3aca584b8591a6e62 /configure.ac
parent36c1f588910ed0d016a8691949ff4228e5019479 (diff)
Run native binary via help2mandebian/2.6.0-8
Bug fix: "runs host arch binaries during build via help2man", thanks to Helmut Grohne. The change from the previous patch is that the flex binary now is created in ./src/ (Closes: #762180). Signed-off-by: Manoj Srivastava <srivasta@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ae2c0d1..426877a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,13 @@ AC_PROG_INSTALL
AC_PATH_PROG(BISON, bison,bison)
AC_PATH_PROG(HELP2MAN, help2man, help2man)
+if test "$cross_compiling" = yes; then
+FLEXexe='flex$(EXEEXT)'
+else
+FLEXexe='$(top_builddir)/src/flex$(EXEEXT)'
+fi
+AC_SUBST(FLEXexe)
+
# Check for a m4 that supports -P
AC_CACHE_CHECK([for m4 that supports -P], [ac_cv_path_M4],