summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2015-12-09 19:39:20 -0500
committerWill Estes <westes575@gmail.com>2015-12-09 19:39:20 -0500
commitd4e8f383e8b86c6b1d7551059b70ea19576c62ba (patch)
treeb87339ca7792bf3d62d4f842bd71a04381affcd6 /configure.ac
parent8205442c7c850f59799a76def5df2f46c76ff307 (diff)
Checked for ranlib and strdup() at configure time
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 86c532a..74ea8c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,7 @@
# autoconf requirements and initialization
-AC_INIT([the fast lexical analyser generator], [2.6.0], [flex-help@lists.sourceforge.net], [flex])
+AC_INIT([the fast lexical analyser generator],[2.6.0],[flex-help@lists.sourceforge.net],[flex])
AC_CONFIG_SRCDIR([src/scan.l])
AC_CONFIG_AUX_DIR([build-aux])
LT_INIT
@@ -47,6 +47,7 @@ AM_PROG_CC_C_O
AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_INSTALL
+AC_PROG_RANLIB
AC_PATH_PROG([BISON], bison, no)
AS_IF([test "$BISON" != no],[],
@@ -124,7 +125,7 @@ AC_FUNC_ALLOCA
AC_FUNC_FORK
AC_FUNC_MALLOC
AC_FUNC_REALLOC
-AC_CHECK_FUNCS([dup2 isascii memset pow regcomp setlocale strchr strtol])
+AC_CHECK_FUNCS([dup2 memset pow regcomp setlocale strchr strdup strtol])
AC_CONFIG_FILES(
Makefile