summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Klausner <wiz@NetBSD.org>2016-11-06 22:32:43 +0100
committerThomas Klausner <wiz@NetBSD.org>2016-11-06 22:32:43 +0100
commit0af671a2750cf44855e29d92cbb7b33abd440c68 (patch)
tree82f6498406d8249fe065f5ad64754f1a2b530ceb /configure.ac
parent14846e5e1ac11488f650afe20f333120ba23c5c5 (diff)
Fix unportable test(1) operator.
"==" is only supported by bash, "=" is the standard comparison operator.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 674c0a0..75fa9d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,7 +55,7 @@ AC_PROG_INSTALL
AC_ARG_ENABLE([warnings],
[AS_HELP_STRING([--enable-warnings],
[enable a bunch of compiler warning flags (defaults to GCC warning flags).])],
- [AS_IF([test "x$GCC" == xyes],
+ [AS_IF([test "x$GCC" = xyes],
[ : ${WARNINGFLAGS="-Wall -Wextra -Wmissing-prototypes -Wstrict-prototypes -Wnested-externs -Wold-style-definition -Wredundant-decls -Wconversion -Wno-unused-but-set-variable"} ])])
AC_SUBST([WARNINGFLAGS])