summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2016-11-26 17:21:25 +0800
committerWill Estes <westes575@gmail.com>2016-12-29 17:19:53 -0500
commit935478c3fe03346f6d6323f00424df07b2f04c70 (patch)
tree1ae89f51adf8280b7edd7453440e65340854731b /configure.ac
parenta33e6fd5b4f0b56255604db4a42edf46ce5d85c0 (diff)
build: allow building libfl even with --disable-libfl.
For various reasons, we may wish to build libfl explicitly even when configure has been run with the --disable-libfl option. This is possible, now, via 'make -C src libfl.la'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5a29b79..7d742c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,7 @@ AC_ARG_ENABLE([libfl],
[AS_HELP_STRING([--disable-libfl],
[do not build -lfl runtime support library])],
[], [enable_libfl=yes])
-AM_CONDITIONAL([ENABLE_LIBFL], [test "$enable_libfl" = yes])
+AM_CONDITIONAL([ENABLE_LIBFL], [test "x$enable_libfl" = xyes])
AC_PATH_PROG([BISON], bison, no)
AS_IF([test "$BISON" != no],[],
@@ -122,7 +122,7 @@ AC_DEFINE([HAVE_LIBPTHREAD], 1, [pthread library] ),
AC_DEFINE([HAVE_LIBPTHREAD], 0, [pthread library] )
)
AC_CHECK_HEADERS([pthread.h])
-AM_CONDITIONAL([want_pthread], [test x$ac_cv_lib_pthread_pthread_mutex_lock = xyes])
+AM_CONDITIONAL([want_pthread], [test "x$ac_cv_lib_pthread_pthread_mutex_lock" = xyes])
AC_CHECK_LIB(m, log10)