summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2017-01-19 16:04:13 +0800
committerWill Estes <westes575@gmail.com>2017-01-24 07:36:50 -0500
commit9c54eb6e30459e74a4de37822b497b0b3dc73995 (patch)
tree9873d7f6025031e99907508f895c2a4566960069 /configure.ac
parent7e4d5387247f4933fccc90539797e4ab4b50e2dd (diff)
build: detect overflow for [re]allocate_array.
Use reallocarray() when we have it (i.e. in OpenBSD system). When we don't, use equivalent overflow detection for our allocate_array and reallocate_array functions. Remove lib/reallocarray.c from our LIBOBJS as we no longer need it. Provide a fallback SIZE_MAX macro definition in flexint.h (not preprocessor friendly, but enough for our reallocate_array use case).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1543de0..c6c5bd4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,7 +157,7 @@ strchr dnl
strdup dnl
strtol)
-AC_REPLACE_FUNCS(reallocarray)
+AC_CHECK_FUNCS(reallocarray)
AC_CONFIG_FILES(
Makefile