summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMightyjo <mightyjo@gmail.com>2015-12-02 21:25:11 -0500
committerWill Estes <westes575@gmail.com>2015-12-03 07:21:48 -0500
commit9e24fe5ea9ae7b2e2193fa3ad881416f12bf43cf (patch)
tree7cd9facfaf5c4964f3c067472debeff6ed1d2525 /configure.ac
parent399e94f904b913a4093295426820ab89fc3cd24f (diff)
Checked for (g)texi2dvi. Better bison, help2man checks.
Added test for presence of (g)texi2dvi program. Gave notice if texi2dvi is unavailable and set TEXI2DVI=: to avoid giving users headaches. Enhanced tests for bison and help2man with notices when the programs aren't found. Set their program variables to use the missing script in build-aux since it's compatible with them.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cc376c8..86c532a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,8 +48,23 @@ AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_INSTALL
-AC_PATH_PROG(BISON, bison,bison)
-AC_PATH_PROG(HELP2MAN, help2man, help2man)
+AC_PATH_PROG([BISON], bison, no)
+AS_IF([test "$BISON" != no],[],
+ [ AC_SUBST([BISON], [\${top_srcdir}/build-aux/missing bison])
+ AC_MSG_NOTICE(no bison program found: only required for maintainers)
+ ])
+
+AC_PATH_PROG([HELP2MAN], help2man, no)
+AS_IF([test "$HELP2MAN" != no],[],i
+ [ AC_SUBST([HELP2MAN], [\${top_srcdir}/build-aux/missing help2man])
+ AC_MSG_NOTICE(no help2man program found: only required for maintainers)
+ ])
+
+AC_PATH_PROGS([TEXI2DVI], [gtexi2dvi texi2dvi], [no])
+AS_IF([test "$TEXI2DVI" != no],[],
+ [ AC_SUBST([TEXI2DVI], [:])
+ AC_MSG_NOTICE(no texi2dvi program found: only required for maintainers)
+ ])
# Check for a m4 that supports -P